Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow Yahoo has been added as the default search provider in Firefox. How can I get rid of it and go back to Google?

I recently installed the "Tab Mix Plus" Firefox extension, so I suspect that this has changed the search provider.

When I enter a set of words which, without the "www", I used to get the proper URL. Now, I get some sort of search which returns nothing close to what I was looking for and proudly proclaims itself to be "Yahoo Search"

I liked Google before and I would like to return to using Google for search. I have looked all through "Add/Remove Programs" in the Windows XP control panel, but it's not there.

share|improve this question
    
Wait… I am confused. Is the Firefox search box up in the top right hand corner using Yahoo for its search now, or are you talking about the Awesome Bar (address bar)? –  David Pearce Oct 3 '09 at 5:12
1  
No, he's talking about the Awesome Bar. the search box default probably also got changed, but that's easy to change back. typical of 3rd-party browser toolbars -- FreeCause has a themable toolbar that's used in a lot of places and does exactly that. this is not Tab Mix Plus. you may have agreed to install some browser toolbar as part of another program's installer. –  quack quixote Oct 3 '09 at 5:33
    
Screenshot, just in case there's more info on that page. –  random Oct 3 '09 at 5:33

5 Answers 5

up vote 6 down vote accepted

You will need to change the default search engine for the address bar. Follow this post. Alternatively you can set the keyword as mentioned in the post to the below value which is present in my browser:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

share|improve this answer
2  
+1 nice solution. beware if you do this without uninstalling whatever changed it in the first place, it might get changed back at a later point. –  quack quixote Oct 3 '09 at 10:34
    
Fantastic. Thanks a lot. –  Xavierjazz Oct 3 '09 at 13:40

There may be a malware plugin "Search Settings Plugin" that was installed without knowledge of the user. Uninstall that plugin and it should fix the problem. You still need to update the about:config to restore to original settings.

share|improve this answer

You didn't state your OS. Under Windows, you may have to go to Control Panel >> Programs (or Add/Remove Programs) and remove the Yahoo! toolbar that way. Also, in Firefox click Tools >> Add-Ons and remove any Yahoo! plugins.

share|improve this answer

The McAfee Site Advisor addon does this. I'm pretty certain all of you have it installed. Here's the proof. This is what the keyword looks like in my about:config http://in.search.yahoo.com/search?fr=mcafee&p= Notice the McAfee at the end? It seems that this behaviour can only be changed with the Plus version of the toolbar. I haven't restarted the browser yet, so can't comment whether MASA will change it back to yahoo or not. And thanks for helping me find the problem.

share|improve this answer

Check out here, this should solve the problem

Have a look at the link, it has detailed guide with pictures and stuff and should help to resolve the problem.

share|improve this answer
    
While this does technically answer the question, it would be preferable to post the relevant parts here and provide the link only for reference. –  Dennis Mar 9 '13 at 1:44

protected by nhinkle Mar 9 '13 at 3:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.