Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install SQL Server CE 4 on a WinXP Pro SP3 machine. I double-click on the file and absolutely nothing happens. There is nothing in the event viewer and the only effect I can see is the addition of an empty, randomly named folder in C:\ which looks something like C:\7c59aaeb5e43f6bdcb2430e923

I've tried this with both SQL Server CE 4 and the SP1 version. I've tried disabling the AV (Nod32) file protection but it didn't make a difference. I've checked the installed program list in case it's already installed, but I don't see it anywhere. I checked in C:\Program Files\Microsoft SQL Server Compact Edition\ and there's only the \3.5 folder in there from the already installed 3.5 version.

Does anyone know what's going on or how I can further diagnose the problem?

Edit in response to Ramhound: I have .NET 4 installed. Why, does it need a particular version?

Edit in response to leinad13 I tried Process Explorer and filtered by the name of the temporary folder created. I see the following, but can't make much sense of it.

enter image description here

share|improve this question
    
What version of the .NET Framework do you have installed? –  Ramhound Nov 8 '12 at 17:32
add comment

1 Answer

What files if any are in the folder : C:\7c59aaeb5e43f6bdcb2430e923 ?

It looks like it is a self-extracting installer, which might be failing to extract the files it needs. (The msi or whatever install program should open after it has finished extracting)

If there are no files in the folder, try running this program Process Explorer - it will display lots of information, so best to filter it by process name and see what files are getting touched etc... when you run the main install file.

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.