Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is that my messages don't seem to sync and neither do I get notifications from the Windows Store App. I have both, the desktop program and the Windows Store App, the problem is that whenever someone messages me I do not receive a notification of the App but I get one from the desktop program. The Skype app is running in the background and does not have disabled the notifications neither have turned on sleep notifications. I have to manually open the app and moreover, open the chat window of the one who is talking to me, then wait like 10 minutes and then the chat will get syncronized. in short:

Notifications don't work even:

  • if computer unlocked and Skype is running in background
  • if computer unlocked and Skype is running in foreground

These doesn't seem to help:

  • Reboot doesn't affects skype.
  • Having only the App opened.
  • Uninstalling/reinstalling

Update

These also doesn't help:

  • Having only the Windows 8 app open.
  • Closing the app and re-opening.

Is there a way to fix this? or is this an issue with the Skype app in Windows 8?

share|improve this question
    
In Metro PC Settings under Notifications, is it on for Skype? Just confirming –  pratnala Nov 9 '12 at 7:50
    
yes, it is on. I even checked that whenever you turn that off it also turns in the application but again everything is on. –  Raykud Nov 9 '12 at 17:49
    
I have troubles with this too, between computers, Windows 7, Mac OS X and my iDevices. Chats never sync properly. –  Henrik Söderlund Nov 11 '12 at 15:39
    
Same issue with win8 pro. –  Cristi Nov 12 '12 at 8:00
1  
I checked this. Gets suspended God knows why and no notifications at all –  pratnala Nov 20 '12 at 13:34

2 Answers 2

If you close the desktop app, the Windows 8 app should notify you as expected.

Skype is a bit weird, it does the same with the iOS client. If I receive a message in the iOS app while it is open, the Windows 8 Skype app won't send a notification.

It seems that as soon as one of your connected apps sets the message as 'read' it disables further notifications to other clients and these clients won't download messages until you open them and wait for them to come in.

In short, Skype in general has issues with notifications.

share|improve this answer

Go to the right cursor windows 8 popup and go to settings 2) on the bottom you will find Change PC Settings > Notifications > Skype > on 3) Also switch on the show app notification and show app notification on lock screen

share|improve this answer
    
As I stated in my question: Notifications are turned on. –  Raykud Dec 6 '12 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.