Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7. I open a shell by typing 'cmd'.

But when I type 'ipconfig' trying to find out the ip address. I get 'ipconfig is not recognized as an internal or external command.

How can I fix this?

share|improve this question
    
Some malware can cause this also, if you think you are infected see this –  Moab Nov 8 '12 at 23:43

2 Answers 2

up vote 1 down vote accepted

In the command prompt type

path

is "c:\windows\system32" included as one of the path variables?

more than likely it is not.

to add it to your path system variable open Control Panel (icon view) and choose "System"

click "Advanced system settings" on the left side, then click "Environment Variables" button. in the "System Variables" section scroll down and highlight "Path", then click edit.

When the edit windows opens it by default will have the "variable value" line highlighted, tap your right arrow key once to remove the highlight and put the cursor at the end of the line, then type:

(be sure to put a semi colon first)

;c:\windows\system32

to add the system32 path to the end, then click ok on all the windows.

If you think you made a mistake editing, click cancel and start the edit again.

.

enter image description here

share|improve this answer
    
A common problem is a space after a semicolon. Everything past it will be ignored. –  Brian Nov 9 '12 at 7:16

It sounds like your path environment variable may have been lost.

  • Go to your system properties Advanced tab (right-click on "My Computer" and go to properties or go to the control panel and click on "System" and then select "Advanced system settings" from the left panel.)
  • Click the "Environment Variables..." button
  • Under "System variables" find "Path" and open it.
  • See if there is a reference under the "Variable value" to "C:\Windows\System32"
  • If none then added it and reopen a command window and ipconfig should work.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.