Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a gmail account in Thunderbird. When I send a message, a new mail notification appears (sound and system try icon), an unread message appears in the gmail All Mail folder, and the account name turns blue.

I have to click on "Sent Mail" or "All Mail" to get rid of the notification. Unsubscribing from "All Mail" is not effective (it still turns the account name blue).

This seems to be popping up elsewhere (example), but nobody has posted a helpful answer.

How do I keep Thunderbird from thinking that a sent message is new unread mail in the All Mail folder?

share|improve this question
    
You should make this portion into a question and then put the information you found in an answer. –  jonsca Nov 9 '12 at 4:09

2 Answers 2

The workaround is to trick Thunderbird to not pay attention to that new notification.

Two steps:

0) First, make sure you're subscribed to "All Mail" if you (like me) thought unsubscribing would solve your problem

1) Create a filter to mark new items in "Sent Mail" as read. Tools -> Message Filters -> select the gmail account -> New

  • apply when: checking mail or manually run
  • match all of the following: [from] contains [youremail@gmail.com] perform these
  • action: [mark as read]
  • OK

This way Thunderbird won't think they're unread. However, at least on my machine the account name still highlights blue and a notification sound is played (perhaps because it can't run the filter fast enough?) So, step 2...

2) Right-click on "All Mail" -> Properties -> General Information

  • UNCHECK "When getting new messages for this account, always check this folder"
  • (you probably also want to uncheck the other box, "Include in search results" so you don't have duplicates in search results, but that's a different issue)
  • OK

Send a test message to yourself or some bogus account to test it, but it should no longer give you a sound notification or turn the account name blue.

EDIT: I discovered that after doing this, new received items still show up twice (once in inbox, once in All Mail), which is suboptimal. I found that simply unsubscribing from All Mail after performing the above two steps solved this last problem without affecting the sent mail problem.

share|improve this answer
up vote 1 down vote accepted

Another (much more elegant) way to solve this is to sign into gmail, and on the left bar with the labels, click "more" then "Manage Labels."

Then uncheck the box for "Show in IMAP" for the All Mail folder. Now Thunderbird won't even know it's there.

share|improve this answer
    
Ok but you will be not able to have acces to any mail of the "all mail" folder... –  ppr Sep 16 at 14:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.