Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a workstation with two monitors and the desktop extended over them. I have a lot of applications open (generally maximized), and I have a personal preference which application is on which monitor (let's say editors on the right, data retrieval and display on the left).

I have recently upgraded to a workstation with Windows 7 and when I power off a monitor (typically when going home at the end of the day), the desktop-expand-over-monitors disables and all applications are switched to the main monitor. (Also the taskbar I keep on the left resizes to about one icon's width.)

This is highly annoying, since I now spend the first minutes of work each day switching the applications back that were on the monitor on the right.

Is there a way to prevent this? (It says no here.) Is there software I could install that can prevent this?

share|improve this question
    
In some graphics driver you can disable automatic monitor detection - see How do I fix monitor detection in Windows 7 –  Robert Nov 9 '12 at 9:49
    
In my case it's an NVidia NVS 310, have been searching but haven't found it yet. –  Stijn Sanders Nov 9 '12 at 16:31
    
Tried 'obstructing' pin 19 on the HDMI connectors and 'Rigorous detection' in the nvidia control panel, but doesn't work, 'Regorous detection' didn't do anything by the way except ask if I want to detect televisions or not. –  Stijn Sanders Nov 21 '12 at 16:14
add comment

2 Answers 2

up vote 0 down vote accepted

In the case with my NVIDIA NVS 310, apparently you can 'force' an EDID on a DisplayPort.

  • Open the NVIDIA Control Panel (from the desktop context menu)
  • Select Workstation, View system topology
  • Next to DisplayPort (1) and (2), there's a link EDID
  • On each DisplayPort, first do Export EDID, then Load EDID

The first time there's a warning about possible damage to monitors when you get EDID's mixed up, which may not be covered by the warranty on the monitor. So don't get the EDID's mixed up!

share|improve this answer
add comment

An alternative is setting the default resolution in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

Under this location you will find all the monitors you had attached and their configuration plus two additional: On starting with "NOEDID" and one starting with "SIMULATED".

Both entries have a sub-key named "00" and inside the two values PrimSurfSize.cx and PrimSurfSize.cy specifying the resolution - by default 1024 and 768.

Change them to your monitors resolution. That should fix the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.