Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What I did:

  1. I visited https://en.wikipedia.org./wiki/Main_Page (yes, there is a dot after TLD)
  2. I got an SSL error (because the cert isn't valid for the domain name with dot)
  3. I visited http://en.wikipedia.org./wiki/Main_Page (not https)
  4. I opened a new tab and entered https://en.wikipedia.org./wiki/Main_Page again
  5. Now Firefox transforms this URL and changes https to http

I don't think that it's a redirect initiated by the site, because:

  • it immediately changes the URL after hitting enter, even before the connection to the site is established
  • when I enter the URL in a different browser, it works

I noticed it with URLs that produced an SSL error. Maybe some kind of caching to prevent that users see SSL errors again? How could I deactivate this without disabling/cleaning the whole cache?


EDIT: Svend Hansen seems to notice the same problem, but his fix was to disable the whole URL bar autocomplete.

share|improve this question
    
Second tab retains https here (FF 16.0.2 on Windows). –  Karan Nov 9 '12 at 22:41
    
@Karan: I found someone with the same problem (see EDIT in my question), and he described another step I also followed before, but I thought it would not be relevant here: visit the http variant, too (I added this step in the question; don't know if it would make a difference for you). –  unor Nov 10 '12 at 5:59
    
Yep, that extra step does it. Will have to see if this behaviour is even officially documented anywhere. –  Karan Nov 10 '12 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.