Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to start a virtual machine on my newly installed instance of Hyper-V on Windows 8. Here is the error message I'm getting:

Could not find a usable certificate. Error: 'Element not found'

I've tried:

  • Re-installing Hyper-V
  • Restarting the Hyper-V service
  • The steps listed here.
  • Installing kb967902 (couldn't install it)

Any ideas?

Edit 1

The error occurs for a single VM that was created through Hyper-V. The VM currently has no OS on it (because it's newly created).

This is the only VM on Hyper-V. I'm simply trying to install XP on a VM so I can do some IE 8 testing.

Edit 2

I've tried all the steps in @MystereMan's answer & comments up to and including a reinstall of Hyper-V.

We've narrowed the problem down to a certificate not existing in vmms\Personal\Certificates.

Edit 3

Host name found: OMS144.WORKGROUP Creating a new certificate using makecert.exe Error: Can't create the key of the subject ('ac9fcedb-e695-4279-817d-fd1c98729dd6') Failed Unexpected Exception!

At C:\Users\OMS 144\Desktop\Untitled1.ps1:44 char:9+ throw “Certificate Not Found error. Check if makecert.exe is successful ...+ ~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ At C:\Users\OMS 144\Desktop\Untitled1.ps1:11 char:20+ 0..100 | foreach { write-host -ForegroundColor White ((gv -ErrorAction Silen ...+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

System.Management.Automation.RuntimeException: Certificate Not Found error. Check if makecert.exe is successful or not

Edit 4

Certificate created successfully:

vmms\Trusted Root Certification Authorities\Certificates\OMS144.WORKGROUP

Error message persists.

share|improve this question
    
Is it just this one specific VM, or does it do this for ANY VM? Where/how did you create the VM? Have you rebooted the host since installing Hyper-V? –  Ƭᴇcʜιᴇ007 Nov 9 '12 at 15:50
    
@techie007, see edit. –  James Hill Nov 9 '12 at 15:57
1  
@JamesHill - Scrap the Virtual Machine and reinstall Windows XP on a new machine. Microsoft provides free virtual machiens for IE testing. –  Ramhound Nov 9 '12 at 16:11
    
@Ramhound - when you say a new windows xp machine, are you referring to a physical machine or a virtual machine? Also, when you say scrap it, do you mean delete it an create another VM? Where would the free ones from $MS come from for IE testing? –  James Hill Nov 9 '12 at 16:16
    
@JamesHill - They are on the Microsoft website. Yes, I mean delete the current virtual machine file, create a new virtual machine, and reinstall Windows XP on it. I must have missed where this was already newely created sounds like you have a hardware compatability problem. –  Ramhound Nov 9 '12 at 20:24

1 Answer 1

Hyper-V requires a CPU that supports Hardware Virtualization an it must be enabled in the BIOS. Verify that your CPU supports this (download CPU-z and check). Check the bios settings for virtualization support.

EDIT:

OK, this problem is probably because of an expired or corrupted certificate. Follow these steps:

  1. Open up a command prompt and type Services.msc. Go to Hyper-V Virtual Machine Management and stop the service.
  2. In the command prompt, type mmc and hit enter. In the File menu, choose Add/Remove Snap-in, select Certificates and then Add.
  3. In the next window select Service Account and Next. In the Select Computer select the default of Local Computer then Next.
  4. Now under the Service Account drill down to the Hyper-V Virtual Machine Management and select it then Finish and OK.
  5. Now in the left hand pane expand Certificates, vmms\Personal and highlight Certificates. In the right hand pane double click on the certificate, should show the Issued To as the host machine name.
  6. On the General tab of the certificate at the bottom it should show Valid from and a starting and ending date. The problem is that the certificate has expired.
  7. Now close the window for the certificate and then in the right hand pane right click and select delete.
  8. Go back to the Services.msc and restart the Hyper-V Virtual Machine Management service.
  9. Back to the MMC console and refresh the Personal\Certificates and you should see a new one there. Double click on it and verify the new valid dates.
  10. To be able to access the VM's now you will either have to restart the VM or simply use the save state then start the VM back up.
share|improve this answer
    
Virtualization is enabled. I'm running a quad core Xeon E5. My hardware should support this. –  James Hill Nov 9 '12 at 20:32
    
@JamesHill - see the update –  Erik Funkenbusch Nov 9 '12 at 21:38
    
+1 for the effort/instructions. I get to step #5 before I can't go further. I have no certificates listed under vmms\Personal. The folder is empty. –  James Hill Nov 9 '12 at 21:46
    
@JamesHill - well, that's the problem. Did you restart the service? Did it generate a new certificate? Did you reboot the computer after installing Hyper-V? –  Erik Funkenbusch Nov 9 '12 at 21:57
    
@JamesHill - Also, check under the Trusted Root Certificate Authorities for a certificate with the name of your computer. Also, look under all the others, and delete any you find. Also, did you disable UAC? If so, that could be a problem. Also run SFC /scannnow and if all else fails, try refreshing the install or doing a new clean install. –  Erik Funkenbusch Nov 9 '12 at 22:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.