Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Windows 8 and trying to start Google Chrome from the start menu fails, doesn't show any error or open the browser. When double clicked on the desktop, it says

Class not registered 

When I run the program as an administrator it works. How to get it working?

The class isn't registered

share|improve this question

7 Answers 7

This seems to be an artifact of this bug, and seems to be caused by a system-wide install, as your screenshot indicates(Chrome is present in Program Files\Google\Chrome as opposed to %localappdata%\Google\Chrome)

Try checking for presence of these registry entries in HKEY_LOCAL_MACHINE (HKLM) & HKEY_CURRENT_USER(HKCU)and delete them:

HKEY_CLASSES_ROOT\Chrome  
HKLM\Software\Classes\Chrome (all of it)
HKCU\Software\Classes\Chrome (all of it)
HKLM\Software\Classes\ChromeHTML\open\command\DelegateExecute
HKCU\Software\Classes\ChromeHTML\open\command\DelegateExecute
share|improve this answer
1  
Thanks for letting me know, deleting the HKEY_CLASSES_ROOT\Chrome fixed it (it seems I didn't have those others). –  MikkoP Nov 10 '12 at 10:48
    
@MikkoP Cheers! –  Sathya Nov 10 '12 at 12:08
  1. Run cmd.exe in administrative mode ( search cmd.exe and right click, run as admin... )

  2. Copy and Paste these each line, one by one in cmd and press enter. Cmd.exe will ask you Do you want to continue? Press "Y" letter and press enter...


REG DELETE HKEY_CLASSES_ROOT\Chrome
REG DELETE HKLM\Software\Classes\Chrome
REG DELETE HKCU\Software\Classes\Chrome
REG DELETE HKLM\Software\Classes\ChromeHTML\open\command\DelegateExecute
REG DELETE HKCU\Software\Classes\ChromeHTML\open\command\DelegateExecute

Here is the screen shot;

cmd.exe administrator mode

Note: Don't mind if cmd.exe print "ERROR: No path found" etc. Just continue to copy & paste and run each line...

Caution - These commands may delete your Chrome plugin ( add-on ) settings...

share|improve this answer

Create this reg file and double click on it to import it

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\ChromiumHTM\shell\open\command]  
"DelegateExecute"=-

[HKEY_CLASSES_ROOT\Chromium\.exe\shell\open\command] 
"DelegateExecute"=-

[HKEY_CLASSES_ROOT\Chromium\.exe\shell\opennewwindow\command] 
"DelegateExecute"=-

[HKEY_CLASSES_ROOT\Chrome\.exe\shell\open\command]  
"DelegateExecute"=-

[HKEY_CLASSES_ROOT\Chrome\.exe\shell\opennewwindow\command] 
"DelegateExecute"=-

[HKEY_CLASSES_ROOT\ChromiumHTM\shell\open\command]  
"DelegateExecute"=-
share|improve this answer
up vote 1 down vote accepted

Sathya's answer worked temporarily but it got annoying not to have Chrome as the default browser. Links didn't work in other programs and so on.

Reinstalling Windows 8 worked. The upgrade process from Windows 7 had messed up something.

share|improve this answer

Try uninstalling it, then reinstalling it.

share|improve this answer
    
Thanks for answering, but the same problem occurs. –  MikkoP Nov 9 '12 at 18:06

I tried in Win8 with another way, right click the exe file, and select pin to start/pin to taskbar then it works.

share|improve this answer

After all of my Googles with implementing my geeky senses to find out the best and 100% working method, Here's a neat solution.

This solution can resolve all of errors related to DLL's with following message that usually happened at Windows : "class not registered"

or Customers may report that when they are attempting to navigate in Windows, such as opening Display Properties, they are experiencing the following error: Explorer.exe – No such interface supported. To resolve this issue, run the following command to reregister all DLL files for explorer.

Steps:

  1. Click Start . In the Search box, type CMD . At the top of the window, right-click the cmd icon and choose Run as Administrator .

  2. At the prompt, type in (or copy and Right Click > paste in CMD):

FOR /R C:\ %G IN (*.dll) DO "%systemroot%\system32\regsvr32.exe" /s "%G"

and press Enter.

This will take several minutes to complete. There will be several C+ Runtime errors that will appear, as well as the system slowing down. Close all boxes that come on the screen except the CMD boxes. Once complete(it will come back to a c: prompt), restart the system and test.

Get Lucky!

share|improve this answer
    
I get the following: At line:1 char:4 + FOR /R C:\ %G IN (*.dll) DO "%systemroot%\system32\regsvr32.exe" /s " ... + ~ Missing opening '(' after keyword 'for'. + CategoryInfo : ParserError: (:) [], ParentContainsErrorRecordException + FullyQualifiedErrorId : MissingOpenParenthesisAfterKeyword –  Ahmed Aug 16 at 0:47
    
as the error eventuates, check the steps and do them exactly as the above (take attention to letters case). –  Sinha Ayman Aug 17 at 21:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.