Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What I am trying to do:

  • Launch Xorg server without udev device manager.

    What I have tried to do:

  • Make sure that /dev/ has all required nodes, such as /dev/input/*.
  • Make sure that all required kernel modules are loaded.
  • Launch Xorg.

    What happens:

  • Xorg starts up as excepted.
  • Xorg loads correct GPU driver and sets right screen resolution.
  • Xorg blocks all input devices (keyboard, mouse), Alt+F[1-12] does not work (can't go back to tty1).
  • Unraw'ing keyboard to take its control from X removes blocking and after unraw I can Alt+F1 back to tty1. Xorg still does not handle any input.

    Why I think that it should work:

  • Same configuration works well if udev is loaded.
  • Loading udev does not add or modify /dev/ contents, all nodes stays same.

    My main question is:

    How to make Xorg input devices work without udev?

    Any additional information about how Xorg really uses/detects/grabs keyboard would be helpful. And any additional information about what udev really does (other than populating /dev/) would also be helpful.

  • share|improve this question
        
    Maybe I should mv ./my.question /stackexchange/unix/linux/? –  Sampo Sarrala Nov 9 '12 at 22:19

    1 Answer 1

    The problem isn't that the device nodes are missing, it's that X wants to talk to udev to enumerate the input devices.

    If you're not going to use udev then I suspect you'll have to write a xorg.conf that declares the input devices manually.

    share|improve this answer
        
    Any suggestions about what should I change / look for? Xorg logs reports that keyboard/mice/serverlayout are loaded (layout tree shows up correctly at xorg log). After that comes two lines saying Automatically adding devices and Automatically enabling devices (both from == default settings). Then most interesting line that says WW Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'umouse' will be disabled.. And yes, I have "kbd" as keyboard driver in xorg.conf. How should it be? –  Sampo Sarrala Nov 10 '12 at 9:20
        
    Still have not found solution for this, however this answer pointed me to right direction. +1 for that. –  Sampo Sarrala Nov 11 '12 at 22:26

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.