Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just tested it with iTunes; after switching the user account (only after logging into another account, to be precise) the audio playback from the account "A" stops. However iTunes continues playing in the background; which I realized after switching back to account "A".

Very frustrating because it kind-of is a deal-breaker for me; the other person should be able to have some personalized settings; while it is still my computer, and the main account has all the music obviously. The ideal solution would be audio output continuing running while user still has the ability to manually pause it...

EDIT: I tested a bit more: "Desktop" apps like VLC don't output sound but continue running; the stock Music.app in Metro pauses the music and continues playing when switching back.

share|improve this question
1  
That's curious, it used to continue playing (audibly) in Win7. Haven't tried in Win8 however. –  mtone Nov 10 '12 at 4:09
    
@mtone thanks for the info; I never bothered so much with user accounts in windows7 so I didn't know about that. –  klyonrad Nov 10 '12 at 10:32
1  
This is interesting, with Windows 7 on a radio playout system we had a presenter account and a separate admin account. Automated playout would continue while switching users to do admin tasks so this would be a block to us upgrading to Windows 8 –  Graham Wager Nov 10 '12 at 10:56
    
i`m having the same problem, but on app switching. –  Nicos Karalis Nov 10 '12 at 18:40

4 Answers 4

Using the WASAPI output plugin in Foobar2000, audio keeps playing when switching users

share|improve this answer

I am running into the same situation. Interestingly, this appears to be a frequently requested feature (muting other users upon logging in) from windows 7. In my case, I have two audio devices - I want one to be always unmuted regardless of the user account, while the other auto-mutes upon changing accounts. I am wondering if MS buried a means of configuring this behavior somewhere in the device configuration or possibly in the registry, but so far I have had no luck finding such info on Google. This may require going directly to the MS audio device team.

Update: I posted my question to TechNet forums - http://answers.microsoft.com/en-us/windows/forum/windows_8-hardware/is-there-a-way-to-not-mute-an-audio-device-when/4e4bc707-8c76-42c6-bbda-b142d6be1f49. The answer for now is that there is no way to NOT mute a device; however, I am looking for ways to submit a feature request for this. If enough people ask, it might get added.

share|improve this answer

On XP, once I enabled concurrent remote desktop sessions, I was able to remote in to our Media PC while people were still logged in and they would be able to hear any sounds I played.

Maybe enabling concurrent sessions in windows 8 will help with your issue?

http://forums.mydigitallife.info/threads/31829-Windows-8-Patcher

http://www.missingremote.com/forums/concurrent-rdp-sessions-windows-8-consumer-preview

share|improve this answer

I find it VERY hard to believe that audio would continue playing in windows 7 if you switched accounts. That just seems crazy.

Imagine you have Skype running on the other account, and the logged in user keeps hearing the Skype call music over and over again.. that would be frustrating.

If it did in fact work that way in Windows 7, I would say it was a bug in Windows 7.

This is NOT how it's supposed to work. As such, don't expect it to be fixed.

share|improve this answer
    
Yeah, I never said that this a flaw on windows' side. Hower I'll be glad to learn about some kind of hack for the behaviour –  klyonrad Nov 10 '12 at 19:59
    
@MystereMan It used to happen in Windows 7. Sound continued to play when you switched accounts –  pratnala Nov 12 '12 at 11:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.