Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two stereo speaker sets. For past couple of days I have been trying to get them to work in 4.0 surround configuration.

What I have tried is connecting one set to the main (Green Connector) on the motherboard and another to the next blue one (see the image). Post this, I have tried various configuration in pulseaudio but to no effect. I have also tried the similiar approach on WinXP (running as guest on VirtualBox) but to no effect. The speaker connected to the main line always outputs sound, while the other one does not give any output at all.

I have tried MPlayer, SMPlayer, audacious, WMP, Winamp and SPlayer with different configurations but no results.

Note: The underlying audio file is encoded as 5.1 AC3. However, I have tried typical stereo MP3, OGG, AAC, MP4 etc.

Motherboard audio ports

share|improve this question
1  
Blue is usually the line in connector (notice which way the arrow points). Green is line out for front speakers and Black is rear speaker output. If you don't have Black, you may only have a 2 or 2.1 audio system. Look up your hardware at the manufacturer's website. –  martineau Nov 10 '12 at 8:09
add comment

1 Answer 1

If you want more channels than stereo sound, then you have to install the HD Audio driver package for the audio (aka soundcard) device. The default Microsoft drivers will not suffice. Windows will not notify you or give any indication that this additional driver is needed, as stereo audio is considered adequate for a PC. You should use the motherboard's (e.g. Realtek, SoundMax) or soundcard's "Driver CD" to obtain this software package.

Once installed, the manufacturer's configuration utility (check the Control Panel) should allow reassignment/re-purposing of the audio jacks. For instance, the Realtek HD Audo Manager (for Windows) would allow you to change from stereo (2 channels) to quadraphonic (4 channels) or 5.1 (4 channels plus center and subwoofer). The blue jack will then be the output for the rear speakers.

enter image description here

Note that some sophisticated audio codecs (e.g. AC3Filter) can interfere with the HD Audio configuration. Just be sure the configurations are the same.

If your motherboard's integrated audio is not HD Audio capable, then martineau's comment applies: you are stuck with two channel audio. (I'm assuming that you are using integrated audio because the photo looks like a mobo rear panel.)

I haven't tried to setup Linux with multichannel audio, so I cannot offer any advice for that OS.

share|improve this answer
    
@Bob - there are motherboards that have only 3 audio ports but can still do 5.1 output. For instance, the ASrock mobo (that's about 4 years old) that I'm using right now. –  sawdust Nov 11 '12 at 1:30
    
But not from one 3.5mm/TRS port. And the ones in that photo are clearly labelled: one line in, one line out, one mic in. –  Bob Nov 11 '12 at 1:36
    
@Bob - I've updated my answer to prove my point. The mouse cursor is over the "blue" jack to reveal its re-purposed functionality - that is - output for rear speakers. –  sawdust Nov 11 '12 at 1:37
    
Well done. I'll just go delete my comments :P –  Bob Nov 11 '12 at 1:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.