Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've started accepting remote desktop connections on one of my machines. If i connect the machine to my router using an Ethernet cable i am able to ping it and connect to it remotely (using RDP). However, if i connect the machine using wireless network i am unable to ping it (or access it using RDP).

Although i can live with connecting that machine using an Ethernet cable i just wanted to know the reason why it doesn't work using wireless. Is the router not able to forward packets to that host if its connected using wireless? If yes, any solutions?

My machine is running Windows 7

share|improve this question
    
Does the wireless network allow sharing? –  pratnala Nov 10 '12 at 9:36
    
Where do we enable this? Is this some windows settings? I am using Windows 7. –  N.M. Nov 10 '12 at 9:40
    
In network and sharing center when you're connected to the wireless network, does it say home network, work network or public network? –  pratnala Nov 10 '12 at 11:08
    
it says Home network –  N.M. Nov 10 '12 at 11:27
    
ok and which firewall are you using? –  pratnala Nov 10 '12 at 11:28
show 2 more comments

2 Answers

It looks like I had the same problem and may very well have the solution for you.

First remark (on RDP): This is disabled by default on Windows 7 and should of course be enabled (computer advanced settings).

Some other remarks (mainly for Pratyush and Bob): I Assume that someone knowing about a command like "ping" and RDP will not be so ignorant to use the wrong IP address to connect to and will probably also have checked the firewall settings on both sides. Neither DHCP or sharing would be the most likely cause for a problem like this. Ping and RDP are have in itself nothing to do with sharing (i.e. in firewall settings). A computer can have working shares for everyone on the network and still not answer to ping or RDP requests. Also the connection type (Private, Work, Domain or Public) should not make any difference, once the firewall settings allow all ICMP and RDP traffic or the firewall is switched off an in case of a domain network group policies causing this problem can be excluded. The function of those connection types differences are mainly to allow security flexibility between the different networks. You would of course want more stringent security settings for public networks than for private or work/domain networks. By (automatically) detecting the right kind of network things can be made a lot easier for those wo change location/network a lot.

Now to the solution. I have been deducting what the most likely cause would be, since - as a rule of thumb, and to my 52 year life experience - the most likely cause of something is not the "most likely" by chance. Quite often it IS the cause, so it is best to check that first.

I have a network wit a few Windows 2003 and Windows 2008 servers, one Desktop Windows 7 all on UTP-LAN, and 3 Windows 7 laptops that I can connect to WLAN and/or UTP LAN.

The symptoms that I encountered with Two laptops, both on WLAN Network and internet traffic on both WLAN connected laptops worked fine (DHCP, DNS, routing, ping to router or internet etc.: no problem) First I checked the correct IP addresses for the WLAN connections on the laptop(s) (DHCP but reserved addresses), because they also have a possible UTP-connecion (wired that is). ping or RDP connection between two WLAN clients connected to the network does not give a reply ping or RDP connection to any UTP-LAN client connected to the network works normally ping or RDP connection from any UTP-LAN client connected to one of those WLAN laptops works normally I temporarily switched off the firewalls on both WLAN clients, just to be sure. But since the problem didn't occur to or from any UTP-connected clients this was actually pointless, so unsurprisingly on both WLAN laptops it gave the same results.

This obviously meant it was a problem only manifesting itself BETWEEN WLAN connected devices, having nothing to do with local firewall settings, and UTP LAN (cable) devices had no sign of this problem. The most likely cause could then hardly be any other than two things: 1. A group policy setting, that disallowed certain traffic on WLAN 2. The Wireless router blocking some network traffic Since I checked Group Policy settings and those are not even applicable for those who don't run a Windows Domain environment and also have this problem, the second option became te most likely.

So I looked at the router WLAN settings and found a setting called "Intra-BSS traffic blocking" I have a ZyXEL P-2811HNU-F1 Wireless router/modem, but this may very well be switched on by default on other devices as well. I disabled this setting and all worked perfectly. Obviously this is a setting that blocks traffic between wireless clients and acts as an extra security for WLAN connected devices (much like a firewall) for otherwise unproteced devices. Think about WLAN printers, TV's or smart phones, who knows what firewall settings those kind of devices have???

P.S.: another possible (but not too likely) cause of this problem could be if the WLAN modem/router can be configured as a router between WLAN and (cable-/UTP-) LAN, having a different IP network range on WLAN tha on LAN. In that case there could be NAT (port forwarding), router setting errors or certain firewall settings at work that cause this problem.

share|improve this answer
add comment

Are you sure you have the right IP address? Check using ipconfig /all.

If you need to remote in, it's best to assign the machine a static address rather than use DHCP - you'll have to do it separately for the LAN and WLAN adapters in the Windows Network Connections settings.

If you assign the WLAN adapter the same IP as the LAN adapter, you must not connect using both adapters at the same time.

If you assign it a different IP, you may need to configure port forwarding on your router if you are connecting from an external network. In this case, it is standard to choose a different external port (e.g. 3390) and forward to the internal IP/port (default 3389). In this case, you would connect using ip:port, e.g. 127.0.0.1:3390.

share|improve this answer
    
> Yes, i am sure its the correct IP address [IPv4 Address. . . . . . . . . . . : 192.168.1.56(Preferred)] –  N.M. Nov 11 '12 at 11:23
    
At this point i am not connecting from an external network so port forwarding may not be the culprit. –  N.M. Nov 11 '12 at 11:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.