Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop computer. I recently formatted it and installed Windows 8 64-bit. All works well, except 1 problem: If I try to put it to sleep, it sleeps and immediately wakes up. It worked correctly on the same machine with Windows XP. It happens any way I initiate sleep - through menu, keyboard button, or after 30 minutes.

I have traced the cause to USB keyboard/mouse:

  • Each such incident produces a system event log (source: Power-Troubleshooter) The system has returned from a low power state. Wake Source: Device -USB Root Hub
  • If I click "sleep" and immediately disconnect keyboard+mouse, then problem doesn't occur: the computer goes to sleep and doesn't wake up immediately.

Additional notes:

  • Motherboard: ASUS , latest BIOS version: AMI 0702, 8/27/2010 (was: 0517, 10/30/2008)
  • Keyboard: Logitech MK260 (wireless keyboard+mouse). Problem also happens with a wired USB Dell keyboard and Microsoft mouse (each separately).
  • Keyboard+mouse are the only USB device. However, problem doesn't happen with other device - tested with a disk-on-key.
  • Device manager has a weird system device called "ATK0110 ACPI UTILITY", which got installed automatically with a 2004 driver from Windows Update. It is claimed to be unnecessary, but it comes back if I remove it.
  • I have disabled all power-on options in the BIOS.
  • In advanced power settings, I have disabled "USB selective suspend setting" and "Allow wake timers".
share|improve this question

3 Answers 3

up vote 8 down vote accepted

From How to Fix a Computer that Keeps Waking Up:

  • To find out which devices can wake up the machine, on the command line run: powercfg -devicequery wake_armed
  • To disable them: Device Manager (devmgmt.msc), select the device, properties -> Power Management -> uncheck Allow this device to wake the computer
share|improve this answer
3  
Link-only answers are not recommended. It would be better if you can summarise the article here in your own words. –  Karan Nov 10 '12 at 14:47
    
It worked! Dave, if you're ever in the neighbourhood, I'll buy you a beer. –  Jonathan Nov 10 '12 at 16:33

Try checking your scheduled tasks as well, I've written a blog post about that: http://ilantz.com/2012/12/21/windows-8-wakes-up-from-sleep-or-hibernation-unexpectedly/

here's a PowerShell script that will disable the wake up feature for all enabled tasks:

Get-ScheduledTask | ? { $_.Settings.WakeToRun -eq $true -and $_.State -ne "Disabled"} | % { $_.Settings.WakeToRun = $false; Set-ScheduledTask $_ }
share|improve this answer
    
:Thank you, but it gives an xml-error? Can you elaborate? –  Phpdna Mar 1 at 18:24

I had the problem with waking up from any mouse movement, even if the mouse was not allowed to "Allow this device to wake the computer" The solution was in disabling this option for keyboard also. After I unchecked "Allow this device to wake the computer" for both mouse and keyboard - my computer sleeps well :)

share|improve this answer
    
This exact solution actually was already suggested and accepted. –  Ramhound Jan 29 at 4:40

protected by Community Mar 21 '13 at 10:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.