Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Fedora 17 on my laptop. A few days ago I updated my fedora (but not upgraded). I shut down my computer and since the next time I turned it on I am hearing a clicking noise all the time from speakers. Even when I plug my headphones in I hear the noise through the headphone. I surfed over the internet and found the following shell commands:

su -c 'echo "options snd_hda_intel power_save=0" > /etc/modprobe.d/snd_hda_intel.conf'
su -c 'echo 0 > /sys/module/snd_hda_intel/parameters/power_save'

I tried them but they didn't work. Here is the part of "lspci" command related to my sound-card:

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

I have to add that my sound-card is working and I can play some audio file, I mean I can hear the voice and noise simultaneously. But everything is OK in windows xp which is also installed on my laptop.

Could it be related to the sound-card driver? If so, how can I revert it to the previous version?

share|improve this question
up vote 0 down vote accepted

I had similar problems (with a different distribution on a netbook).

What helped me was adding

options snd-hda-intel single_cmd=1

to /etc/modprobe.d/50-sound.conf.

share|improve this answer
    
Up to now it is working, I am not hearing that noise anymore. Thank you very much. I will mark your answer as accepted after I test my computer for a few days. But in the meanwhile, would you mind telling me what does that option do? – Mehrdad Nov 10 '12 at 15:53
    
@Mehrdad: That's what I do not know :-) The documentation states: Use single immediate commands to communicate with codecs (for debugging only). I just tried it out of desperation and it worked. – choroba Nov 10 '12 at 15:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .