Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have one Sapphire Radeon HD 6950 2 GB DDR5 Graphics card in my computer.

Everything used to work great. One day my friend and I flipped the switch on it to enable overclocking and I overclocked for a little while. Everything was great. I only overclocked a little bit, nothing too crazy. The default is 800 Mhz, I think I bumped it to 850 Mhz tops.

A couple weeks later I purchased a 1080p monitor to go along side my 1650x1050. Everything was still going great.

A couple weeks after the monitor purchase, I notice that both of my monitors are flickering like crazy. Whenever I move the mouse, or scroll on a browser window for example. Horizontal lines are flickering all over the place. Almost looks like some of the image is displaced in a different location, but happens very fast.

I've realized that if I go into my resolution settings and change the resolution on the 1080p monitor from 1920 x 1080 down to 1650 x 1050 and then SET IT BACK UP to 1920 x 180, everything works great until I reboot the computer. I forget there is even a problem until that point.

I have now disabled the overclocking, and the flickering still occurs on startup.

Does anyone know what could be causing this? And why it is being "fixed" when I reset the resolution manually?

Update I just updated my motherboard BIOS, still flickers.

share|improve this question
    
possible duplicate of Horizontal lines flash randomly over laptop display – Rosenthal Sep 29 '14 at 23:33

Change your Power Plan settings

The power plan is limiting the resources for the graphics card to function properly. Change all the settings to the Maximum Performance.

How I fixed the problem:

  • Install the latest drivers from the official AMD website (Catalyst 14.0+).

  • Change you Power Plan to High Performance (in battery and plugged-in).

  • Go to Control Panel>Power Options>Change advanced power settings> ATI Graphics Power Settings> ATI Powerplay settings> On battery, Plugged in: Maximum Performance.

  • Go to Control Panel>Power Options>Change advanced power settings> PCI Express> Link State Power Management> On battery, Plugged in: Off.

  • Disable Aero (Choose the Windows 7 Basic theme)

  • Restart your PC.

Important: This will also fix a constant change in the brightness level when you switch between dark and bright apps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .