Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My brother's PC has stopped working. He now cannot boot into windows, and he can't access BIOS by pressing the DEL key as no keyboards work. He has tried 4 different keyboards, one of which is PS/2. He tried the USB keyboards on all the USB ports.

I don't know why the BIOS would show the message "Floppy disks fail (40)", as there is no floppy disk drive in the PC.

He has upgraded from XP to Vista (yes that's right, upgraded keeping the XP drivers, eyes roll).

A BSOD occurred in Vista while he was browsing files.

What steps should be taken to troubleshoot the problem?

enter image description here

share|improve this question
2  
Try to replace CMOS battery. –  Corvus Nov 10 '12 at 18:22
    
The floppy disk drive detection is failing because there's no floppy drive, yet the BIOD is set to expect there to be one. what's the actual BSOD stop code you get from Windows? –  Ƭᴇcʜιᴇ007 Nov 11 '12 at 3:36
    
Go into the BIOS setup and disable the non-existent floppy (normally F2 in boot). Ensure also that boot is from the hard disk. –  harrymc Nov 14 '12 at 16:18
    
Can't get into BIOS; that's the whole point. –  Truncheon Nov 14 '12 at 20:31
    
Did he plug the PS/2 keyboard in before he powered the machine on? How does he know the PS/2 keyboard isn't defective? Please edit the question to reflect that information, then flag this comment as "obsolete" to get it deleted. –  unforgettableid Nov 15 '12 at 18:12

1 Answer 1

up vote 1 down vote accepted
+100

This looks like an EVGA nForce™ 680i SLI Motherboard from about 2008. This board supports a floppy drive. If it is not present then the BIOS value must be set to reflect this.

This setting (and many others) is then stored. To prevent this from information from being lost when you turn off the power there is a small battery on the motherboard.

However that battery will slowly age and after a few years it will no longer suffice. When that happens the values in the BIOS might either get corrupt, or they can revert to the defaults.

Looking in the manual for your board this is the relevant default: Image of the floppy config in the BIOS

Combine that with a motherboard which is about 4 or 5 years old and you have the likely cause for your problems.

Usually you can fix this by pressing the relevant key (in your case DEL), going into the BIOS and changing the values to reflect your system. For some reason this does not work for you.

The failure of the USB keyboard is understandable. With unknown settings in your BIOS they might simply not be supported.

USB keyboard settings in BIOS

However the PS/2 keyboard should have worked.

Could you:

  1. Confirm that the (probably old) PS/2 keyboard works on another computer? Then
  2. Plug it into the keyboard PS/2 plug (orange or purple IIRC)
  3. Only now power up the computer.
  4. Press DEL repeatedly.

This should either result in a lot of beeps (keyboard works, not to get the DEL timing right!), or drop you in the BIOS.

From there you can reset the values, and boot windows.

The next time you boot you will have this problem again until you replace the battery.

Disclaimer: All of this assumed the battery is empty. Which is a safe assumption after 5 years. There is always the possibility then something else broke. That would explain why a BSOD occurred in Vista while he was browsing files.

share|improve this answer
    
Sorry I can't up vote this; I used up all my rep to give the bounty. Hopefully someone else will up vote you soon. –  Truncheon Nov 15 '12 at 21:55
    
Hopefully it is the battery. Slowly loosing power might have resulted in wrong timing values and thus an unstable Vista. Still no guarantee, just a likely cause based on a one page description. –  Hennes Nov 15 '12 at 21:58
    
Battery would definitely cause the floppy disk error.He can't get into the bios with no working keyboard though –  Journeyman Geek Nov 16 '12 at 1:01
    
We'll try a USB adapter PCI card if all else fails. –  Truncheon Nov 16 '12 at 15:24
    
Sadly that should not work. It is normal for an USB keyboard not to work. To use it at all before your OS loads drivers you need to have support for it in the BIOS. (Consider the BIOS its own OS with limited drivers). If that support is turned off then it will fail. :( –  Hennes Nov 16 '12 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.