Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working on a ruby on rails app. All of the sudden the command line tab complete stopped working for vim, only for files though, and only for the vim command (i.e. works for other commands, ls, rm etc.)

After further investigation - this only occurs in a specific directory, the home directory of my rails app. If I go into a sub directory in my rails app, or any other directory on my machine, the tab complete works again. If I go into the root directory of any other rails app, it works. I also tried renaming the diretory, and copying the contents of the directory to another directory, and that did not work either.

It only does not work for files, and works for any other command - ls, rm etc. But when I do vim /path/to/file/, then tab to see a list of files in that directory, only other directories show, not files.

I am using ubuntu 12.04. Also, I tried re-installing vim, re-booting, removing ~/.viminfo (there was no vimrc file) that didn't work. Any help would be appreciated!

share|improve this question

migrated from Nov 10 '12 at 22:12

This question came from our site for professional and enthusiast programmers.

That tab completion (like the tab completion for ls, rm) is not done by Vim but by your shell. What shell do you use? Could you add it to the tags of your question? Could you post the content of the *rc file(s) loaded by your shell? Could you compare the privileges of those directories and files? Also I'm not sure this question belongs to stackoverflow. – romainl Nov 10 '12 at 13:40

1 Answer 1

Figured it out - not quite sure how this affected tab completion with files, but there was a file in my application home directory called "!" (likely erroneously created when I typed :wq! too quickly in vim). When I removed the file "!", tab completion worked fine again.

share|improve this answer
Hi, you might want to associate your two accounts so that they can be merged and you can accept the answer to this question. (I assume this is your question, since you answered it as such.) – Michael Hampton Nov 11 '12 at 15:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.