Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop display will turn off for two reasons: Either I leave my computer idle and the display automatically turns off, or I close my lid and then just the display turns off. When I am using it, my computer is very quiet, and it doesn't get hot at all from the CPU, but as soon as the display goes up (well give it about 10-15 seconds), then the fan starts roaring.

This problem only happened when I upgraded to Windows 8. I have a Sony laptop, S series, specifically VPCSE1AFX. I have 2nd gen i7 quad-core processor (i7-2640M). I am not sure what other details to provide, but I am wondering if anyone else has had this same problem and/or knows how to fix this? This has been extremely annoying.

share|improve this question
    
How long does the fan stay at high speed? It's possible the system is just taking advantage of idle time to do maintenance. –  David Schwartz Nov 11 '12 at 4:28
    
@DavidSchwartz it stays at high speed for as long as the display is off. It starts 15 seconds after the display goes off, and it takes only about 15 seconds for the fan to go back to normal speed right after the display turns back on. –  Sidd Nov 11 '12 at 17:38

3 Answers 3

This looks very much like Windows Automatic Maintenance.

You can confirm this (or anyway inveestigate the problem) by installing the latest Process Explorer and running it. Set it to display CPU load (Ctrl-I, I believe). Then, idle the PC, wait 15 seconds for the fan to rev up, wait another ten seconds to get a significant log, and exit idle status. The graph will almost surely show a CPU peak in the "blackout" period, and hovering the mouse over the graph will tell you what process was responsible.

In case it's indeed the maintenance process MSchedExe.exe, or if you just want to assume it is and see what happens, you can simply disable it (you can reenable it later. Or schedule it at night by having the PC automatically wake up).

  • open Settings
  • open Scheduled Tasks
  • open Library -> Microsoft -> Scheduler
  • look for Idle Maintenance Task
  • right-click to bring up the Task Menu
  • disable the task
  • OK close all
  • see what happens now

You'll do good to manually defragment your drive and/or run the .NET Optimizer from time to time, now that Windows won't do this on its own.

Personally, I feel that there are other tools that perform the same tasks better (jDefrag and various defraggers that operate on idle time, Piriform's CCleaner, AusLogic BoostSpeed etc.), but I'm not really into Windows 8, so take my advice with a large grain of salt.

share|improve this answer

Did you perform an upgrade or a fresh install of Windows 8? Upgrades of operating systems, on any platform, are generally not recommended, and can cause such oddities as you are describing.

Aside from that, I would recommend ensuring that your display (video) drivers are up-to-date, and also your Intel chipset drivers. You can download the chipset drivers directly from Intel Support (http://intel.com), and you can download Windows 8 64-bit drivers for all your other devices from Sony's support website.

Here is the URL for your particular model:

http://esupport.sony.com/US/p/model-home.pl?mdl=VPCSE1AFX&LOC=3#/downloadTab

Make sure you apply both of these video drivers, since your laptop most likely has both devices installed. You can open Device Manager by pressing [Windows] + [X], [G], {Enter}, and then confirm which devices your laptop has under the Display Adapters heading.

If your laptop has a Radeon adapter, then install this driver:

AMD Radeon™ HD 6470M / 6630M and Intel® HD Graphics Update 11/01/2012 9.1.0.0

If your laptop doesn't have a Radeon adapter, then install this driver:

Intel® Graphics Driver 10/11/2012 9.17.10.2843

As for the Chipset drivers, instead of downloading them from Intel, you can download them under the Motherboard heading from the Sony Support URL.

Intel® Chipset Driver 10/02/2012 9.3.0.1021.0831

share|improve this answer
    
I did a fresh install, and all of drivers are up to date. Although I did use a program called Driver Genius (the reason being I have two graphics cards but , but I can try going through sony's drivers. Thanks –  Sidd Nov 11 '12 at 1:33
6  
Those "driver installers" are very sketchy. I would recommend doing a fresh install without using Driver Genius, or any similar programs. –  Trevor Sullivan Nov 11 '12 at 1:37
    
Hmm that was my first inclination...I only used it because my laptop has hybrid graphics (both Radeon and Intel, thats why you see both of those graphics drivers in there) but before, they did not have a Radeon graphics update, and I really needed that graphics driver..it looks like they recently updated their website. –  Sidd Nov 11 '12 at 1:53
    
Radeon drivers for hybrid graphics can't be downloaded from AMD website, you have too look for them on Sony website. There may also be some additional utilities that enable advanced power management features on your laptop, those should be available at manufacturer's site too. –  gronostaj Apr 26 '13 at 21:55
    
Driver genius is an excellent program, it downloads always from the device vendor page, and I have always the most up to date drivers and no problems ever :) so what's this big "Driver installers are sketchy" problem? They just look for a certain Hardware and Vendor ID and the download the drivers from the official websites (intel,nvidia,ATI,etc). –  Gizmo Aug 31 '13 at 20:00

it,s happen because your system does not match with one of net framework component, try uninstall all net framework 4.5 from your system, it's happen to me and solved

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.