Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have no internet access on my Windows Phone 8emulator that I run in Windows 8 through the Visual Studio 2012. I know this because for one, I cannot open any website in the Internet Explorer within WP8 emulator.

The desktop on the other hand (on which the Windows 8 is running) has Internet access (I can browse websites without any problems in Windows 8). So, I have internet in Windows 8 instance I’m running, but I don't have in the Windows Phone 8 emulator that is run on that OS.

I don’t have any router in my home. I have the ethernet cable that I got from my internet provider connected directly to my network card in my PC. My IP is set staticaly, and is public.

Now all I did so far, was open Visual Studio and run an emulator. Once it loaded, I quit my mock application, picked Internet Explorer tile and tried to open couple known websites, all failed to load. I did not change any settings in an emulator, nor did I do anything else with the emulator image.

What I expected, was same behavior as with Windows Phone 7 (7.0 and 7.1) emulator. I ran emulator and I had instantly internet access on it, as long as my desktop internet connection was working. Here is not the case.

I would like to repeat one thing. I don't have a router. I did not change any settings in Windows 8 concerning network, all I did was run emulator and notice that it doesn't have internet access within it.

share|improve this question
Have you verfied this isn't a Windows Firewall problem? – Ramhound Nov 11 '12 at 16:06
up vote 6 down vote accepted

The Windows Phone 8 emulator runs in it's own (Hyper-V) VM with it's own networking and MAC addresses.

Using the Hyper-V Manager --> Actions --> Virtual Switch Manager, check the setup of the virtual switch; I believe that by default it's set to "Internal network" which mean no outside access.

"An internal virtual network is not bound to a physical network adapter. As a result, an internal virtual network is isolated from all external network traffic."

enter image description here

Since you say you have no router and just plug the host directly into the ISP's network to get Internet, you'll need to figure out a way to share the network connection. Either by changing the virtual switch setup to bind to an actual (extra) physical adapter in the host, which is then hooked into a router or alike (to split the network connection from the ISP), or by keeping it as "Internal Network" and then enabling Internet Connection Sharing on the host (so it acts as a router).

enter image description here

More info on setting up Hyper-V's networking from MS here: Configuring Virtual Networks

WP8 emulator troubleshooting covers it as well: Troubleshooting the Windows Phone 8 Emulator

Here's some instruction on how to setup ICS for Hyper-V VMs on Windows 8: Share Internet Connection with Hyper-V Guests (NAT) on Windows 8

share|improve this answer
Thank you techie007! That lead me to a solution, which works, not entirely(check the the next message bellow this), but I finaly have an internet on WP8 emulator without the need of an external router. What I did wrong before when I was batling this problem was sharing the internet connection of my original "Ethernet connection", while what I had to do was share the new created virtual switch for that connection. Once I did that, the internet appeared in WP8 emulator. So thanks a lot for leading me to it! – Lucas Nov 12 '12 at 13:30
However, amazingly, when I did that, I was not able to run WP8 emulator within Visual Studio! Once I disable sharing of the internet though, everything is back in order! I post below the link to the following problem:… – Lucas Nov 12 '12 at 13:32
@techie007 nice answer but For the above setting not works for me i didn't have the external router – Spynet Feb 21 '13 at 9:17

Try this solution, it works for me (no need of DHCP):

  1. Using Hyper-V start the server, once started you can see the two new network adapters added in the (network sharing) page.

  2. Go to your visual studio IDE where your application runs, using Emulator run your application, once started try to open IE, it will not connect to internet.

  3. Now again come back to network sharing page right click on external adapter which was created newly select properties, hit on sharing tab, now check the two options to have tick mark if not tick that two options and click on OK.

  4. Internal adapter which was created newly will be changing the domain name from Unidentified network to your shared Domain name, once changed try to access the Internet Exporer again in emulator which runs already. Now I hope the internet connection works.

share|improve this answer
This is just a round about way of doing what the accepted answer has you to do. – Ramhound Feb 21 '13 at 12:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.