Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

During the startup I see machine executing this thing for about 30 seconds:

udev: waiting for uevents to be processed

Then I get a quick message which says something like:

devfs: timeout (50 seconds)

I can't see the whole thing because after that system starts up very fast including Xfce.

What logs and configs do I need to provide for further investigation?

$uname -a

Linux genta 3.6.6-gentoo #1 SMP Sun Nov 11 11:02:23 NOVT 2012 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz GenuineIntel GNU/Linux

Thank you!

UPD: rc-status

genta / # rc-status sysinit
Runlevel: sysinit
 dmesg                                                             [  started  ]
 udev                                                              [  started  ]
 devfs                                                             [  started  ]
genta / # rc-status boot
Runlevel: boot
 hwclock                                                           [  started  ]
 modules                                                           [  started  ]
 fsck                                                              [  started  ]
 root                                                              [  started  ]
 mtab                                                              [  started  ]
 localmount                                                        [  started  ]
 sysctl                                                            [  started  ]
 bootmisc                                                          [  started  ]
 hostname                                                          [  started  ]
 termencoding                                                      [  started  ]
 keymaps                                                           [  started  ]
 net.lo                                                            [  started  ]
 swap                                                              [  started  ]
 urandom                                                           [  started  ]
 procfs                                                            [  started  ]

UPD 2: kernel-config

genta / # cat /etc/kernels/kernel-config-x86_64-3.6.6-gentoo | grep 'DEVTMPFS\|UEVENT'
CONFIG_UEVENT_HELPER_PATH="/usr/bin/udevadm"
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
share|improve this question
add comment

3 Answers

For further investigation you can configure udev to report more verbose messages by editing /etc/udev/udev.conf to the following and rebooting:

udev_log="err"

You can set it back to "info" after finished debugging. Messages from udev should now be reported to the var/log/messages file. Hope this helps.

share|improve this answer
    
Here's the messages output –  user157378 Nov 12 '12 at 2:56
    
@stan31337 Please add any additional information to your question rather than editing answers –  Paul Nov 12 '12 at 4:20
    
@Paul sorry, my bad... –  user157378 Nov 12 '12 at 4:22
add comment

When you compile your kernel, make sure the following configuration options are set in your Drivers -> Generic section:

CONFIG_UEVENT_HELPER_PATH="/usr/bin/udevadm"
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

These are not the defaults.

Also run these to add to your init:

rc-update add sysfs sysinit
rc-update add udev-mount sysinit

Are you using an initramrs? Do you have /usr on a separate partition?

share|improve this answer
    
I've changed CONFIG_UEVENT_HELPER_PATH and recompiled the kernel. Other two options were enabled. –  user157378 Nov 12 '12 at 2:51
    
And remove devfs from all of your runlevels. You don't need it. –  Keith Nov 12 '12 at 3:33
    
After removing devfs from all runlevels the system was starting few seconds slower, and after that I could not launch chromium. /etc/init.d/devfs start helped, so I've returned devfs back to sysinit where it was. –  user157378 Nov 12 '12 at 3:55
    
ok. I assume you are booting your new kernel? –  Keith Nov 12 '12 at 4:02
    
Can you update with the status of rc-status sysinit and rc-status boot? –  Keith Nov 12 '12 at 4:03
show 6 more comments
up vote 0 down vote accepted

I've been finally able to fix this thing.

The thing is - I have two partitions: /boot and /, but I was using initramfs to start the system. At that time I wasn't quite sure if I need it or not, but now after gaining some experience (building LFS ;)) I understood that I just don't need it, and removed the initrd line from my /boot/grub/grub.conf file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.