Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying this guide for having access to emerge on chromeos.

http://www.chromium.org/chromium-os/how-tos-and-troubleshooting/install-software-on-base-images

Unfortunately I always got the same error which is

$ sudo dev_install
Starting installation of developer packages.
First, we download the necessary files.
Downloading https://commondatastorage.googleapis.com/chromeos-dev-installer/board/daisy/full-3.168.0.0/packages/app-misc/mime-types-8.tbz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   127  100   127    0     0    252      0 --:--:-- --:--:-- --:--:--   305
[: 184: -ne: unexpected operator
Extracting /usr/local/portage/packages/app-misc/mime-types-8.tbz2

I think that it somehow returns a 404 everytime. Thanks for your help

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The problem is that commmondatastorage.googleapis.com doesn't handle non-existing stuff in standard way, so instead of returning code 404 when it cannot find the data it will return non-sensical XML document.

All that said your problem lies in incorrect binhost being used to download required packages. What I tried was this:

dev_install --binhost=https://commondatastorage.googleapis.com/chromeos-prebuilt/board/daisy/full-15.11.12.140004/packages

Unfortunately this doesn't solve the issue really since that binhost doesn't have python-2.6.8.tbz2 which is needed in later parts of installation. It's still a good start for investigation though I believe

share|improve this answer

You are right: the file that it is trying to download does not exist. You could try downloading it from somewhere else and saving it as /usr/local/portage/packages/app-misc/mime-types-8.tbz2; dev_install will probably not try to download it again. If it does, you could try modifying the script (let me know if you need help with that). Unfortunately, if you cannot find the file, there is not much that you can do until Google fixes it.

share|improve this answer
    
Thanks for the quick answer. Do you maybe know where I can find this file ? –  user1027721 Nov 11 '12 at 20:33
    
A quick Google search for "mime-types-8.tbz2" (with quotes) turns up a few, although they are not all identical. If you are willing to trust them, try one at a time. If one produces more errors later, it was probably not the right one. –  user130039 Nov 11 '12 at 20:59
    
So I've been investigating a bit more link but still I couldn't make this chromeos-dev build properly. So, to be continued... –  user1027721 Nov 14 '12 at 11:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.