Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem:

Boot time delay caused by udev. Early after initscripts starts there is message saying waiting for uevents to be processed and causing delay on boot, it seems that udev is looking if there is disc in dvd tray. After udev has found disc, boot process continues normally.

Main question:

How to prevent udev dvd lookup at boot time?

Maybe there is some way to skip some udev related stuff and let boot process continue and then later instruct udev to do stuff that may cause some delay (delay in uevents, but not in main boot process, is acceptable after udev is initially loaded).

share|improve this question
    
Did you define any rules for udev? –  Nessuno Nov 15 '12 at 15:17
    
@Nessuno no, I have not defined any rules. However there is two automagically generated configuration files under rules.d: 70-persistent-cd.rules and 70-persistent-net.rules and it seems that *cd.rules is just for /dev symlinks. –  Sampo Sarrala Nov 15 '12 at 20:14
    
Ok then define a rule. Create /etc/udev/rules.d/90-hide.rules The content should look like: KERNEL=="sr0",SUBSYSTEM="block",OPTIONS==”ignore_device” Be sure you check the device attributes first: udevadm info --name=/dev/dvd1 --attribute-walk –  Nessuno Nov 16 '12 at 10:15
    
@Nessuno does not make any change, I believe that correct way to define options is OPTIONS="ignore_device" (one = instead of two for assignment) so tried also that. I've also tried to get selector from existing udev symlink helper rules, it seems that nothing changed and I believe that device selector for rule is correct (it works well for symlinks). –  Sampo Sarrala Nov 19 '12 at 8:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.