Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I've a large number of files, over 10,000, which I want to upload in FTP server. Now, I can't zip those files & upload it as I've to read those files individually in SAS software for my analysis.

If I use mput command, then the prompt as me to say "y" each time it tries to upload the file. This is very cumbersome. Is there any method by which it automatically upload the files without I've to manually entering "y" each time file wants to upload?

The command I was using was:

ftp ftp.myftp.com  *my ftp server name
username:myusername
password:mypassword
ftp> lcd c:\local_folder
ftp> mput *.*
share|improve this question

migrated from stackoverflow.com Nov 11 '12 at 22:18

This question came from our site for professional and enthusiast programmers.

marked as duplicate by techie007, Heptite, Kevin Panko, Tog, Excellll Apr 23 at 13:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer

up vote 1 down vote accepted

You can use the prompt command before mput to turn off the prompting behaviour.

share|improve this answer
add comment