Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently noticed that whenever I click a HTTP link in an application (my mail client for example which is Windows Live Mail), My standard browser opens like only 15-20 seconds later. It also happens from other applications like Skype.

Now I've also noticed that an e-mail link responded with the same time (about 25 seconds!) before the "new mail" window opened. I clicked an e-mail adress in a PDF using Foxit Reader.

This happens only once per system boot as far as I know. The subsequent times it is way more responsive.

It also does not matter whether the receiving application already had a process running or not.

Even opening a new instance of the receiving application actually happens faster than it takes for the link to "arrive". That is, if I click an http or email link somewhere and then open my browser or mail client, the latter open more quickly than the thread that gets opened from the link.

Update: I think I have found the culprit!

The culprit did not appear to be something starting up with the system. It is something that starts whenever I click any kind of link (mailto, hyperlink, ...). The culprit is citrix receiver. This is something that I need to connect to a virtual citrix desktop from school. All of my classmates have this application too, but they don't have the same problem.

The problem is, it starts up with every link I click. Once it is open and done doing whatever it tries to do, it remains open and everything is normal speed again. But when I close the program from the system tray, the first link clicked will be slow again. Note that when waiting for a link, it immediately finishes upon closing the newly opened instance of citrix receiver (the one that "hangs")!

I do not know why it shows this behaviour, and re-installation changed nothing. Would anyone know how to prevent this from happening? I really need it, unfortunately... And I prefer not to make it boot with Windows.

share|improve this question
    
This occurs even if it only opens a new tab in the currently running instance of Firefox...? –  allquixotic Nov 14 '12 at 17:51
    
@allquixotic indeed, as stated in the question it does not make a difference. –  MDeSchaepmeester Nov 14 '12 at 18:15
1  
Mabye its similar problem like this: <superuser.com/questions/41935/…; –  Aivar Luist Dec 2 '12 at 21:43
    
@AivarLuist good find! It certainly does seem that "DDE" (whatever that is) might be the the culprit. That makes me think something that uses DDE starts up with windows and then hangs... –  MDeSchaepmeester Dec 2 '12 at 22:30
    
What happens if your start windows in Safe Mode? –  That Brazilian Guy Dec 5 '12 at 16:58

2 Answers 2

So I guess Firefox is your default web browser, right? What if you change it to Chrome or IE and then try opening up URLs from other applications? Would that make any difference in terms of responsiveness?

Also, have you tried to re-install Firefox (just clean install, no add-on, theme, or persona etc) and see how it performs?

Sometimes, some anti-virus/firewall software will probably capture and scan the URLs that you clicked on and will send anonymous data to their server for real-time protection.

share|improve this answer
    
I have now discovered it's the same thing with IE. There may very well be a point with that antivirus software though! I'll disable it and rerty. –  MDeSchaepmeester Nov 17 '12 at 16:52
    
Disabling my antivirus did not help... Also I have Windows Defender disabled and the firewall settings are all default. –  MDeSchaepmeester Nov 17 '12 at 17:15

This could be a problem related to one or more of your add-ons doing its daily update.

Try to disable all add-ons and see if there is an improvement.

In case of improvement, you could try to re-enable them one-at-a-time (or several-at-a-time), until you find the one that is slowing the startup.

share|improve this answer
    
Thanks for your suggestion but it didn't help. I disabled all extensions and plug-ins, only custom thing I have is my theme but that's unlikely to be the cause isn't it? –  MDeSchaepmeester Nov 17 '12 at 14:18
    
The theme probably doesn't matter. The slow-down is maybe when Windows reads Firefox from the disk, then leaving it there for the future. If you have SuperFetch enabled, then I don't think you can improve this except by getting a faster disk or trying another browser (Chrome is reputedly the fastest). –  harrymc Nov 17 '12 at 15:31
    
since it's the same with IE as a standard browser, I don't think it will matter much which browser I use. Besides I prefer firefox over chrome. SuperFetch is enabled, though I'd think it would rather improve things than slow them down. Also, as I said, when normally opening firefox, it's fast enough. I can even open a new firefox window before the clicked link does so. –  MDeSchaepmeester Nov 17 '12 at 17:17
    
I meant for SuperFetch to be enabled. IE is built-in to Windows, so if performance is the same then the problem is not hardware. You have tried with firewall & antivirus off, so what's left is to try it in Safe Mode With Network boot. This will tell you if the problem is because of any installed product. –  harrymc Nov 17 '12 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.