Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I remember fixing this error on an old PC of mine. It involve a SIMPLE Internet explorer option change but I can no longer find it.

Any idea?

share|improve this question
add comment

2 Answers

I have this sometimes and what fixes it for me is right clicking the file, then clicking the unblock button.

If this is a .chm file from another machine, it has a NTFS flag set for downloading. Clicking this button clears the flag.

I have no idea why other files work but for some reason, .CHM files are affected... I guess it is to do with the way it caches the html pages.

alt text

share|improve this answer
    
Is this a Vista only button? I don't see it on XP. –  DaveParillo Oct 4 '09 at 4:41
    
No, It was added (I think) In XP SP1 or 2... It is only there on a few types of files when downloaded - not everything. In the above example, it was an archive I downloaded from sourceforge. –  William Hilsum Oct 4 '09 at 9:02
    
I have Windows XP SP3 and I do not see such a button. As I mentioned before, I remember fixing this issue before with some IE option... –  Chad Oct 4 '09 at 18:59
add comment

In addition to the blocking "feature" Wil noted, a few years ago, microsoft released a security update that prevents chm files from executing from remote drives. If thisis your problem, you can copy it locally or lower the restrictions on the Local Intranet zone to allow CHM files to be displayed:

  1. Click Start, click Run, type regedit, and then click OK.

  2. Locate and then click the following subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions If this registry subkey does not exist, create it.

  3. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.

  4. Type MaxAllowedZone, and then press Enter.

  5. Right-click the MaxAllowedZone value, and then click Modify.

  6. In the Value data box, type 1, and then click OK.

  7. Quit Registry Editor.

share|improve this answer
    
It was already set to 1 –  Chad Oct 4 '09 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.