Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I’m running Windows Home Server PP2 in my home, with 3 client computers: two XP and one Vista. I have a router that provides my local DHCP and the server has a static IP address.

The other day the Vista machine hung, and on reboot stopped resolving local names. It will show the green home server client icon in the system tray, but if I attempt to log in to the console, I get a “This computer cannot connect to your home server” message. If I ping the server name from the command line, it does not resolve, and gives a “could not find host” message. Oddly enough, if I browse the network, I can see the server, but double clicking on it fails.

The other machines on the local network have no problems seeing the server, and the Vista machine has no problems resolving names from the internet, it just can’t see any local machines.

I’m aware that I can work around this by adding entries to my HOSTS file (it does work), but I’d like this to work the way it’s “supposed” to. I’m an experienced computer user and developer, but not a networking whiz. Can anyone tell me how local name resolution is supposed to work in my environment and/or suggest ways to troubleshoot this?

share|improve this question
    
More Info: I've discovered that even with adding the server to the hosts file, I can't browse files on the server, nor print to the server's printer. –  AndrewCr Oct 3 '09 at 19:29
add comment

2 Answers

Try restarting the router - if it is a cheap/standard one, it could be that it only adds DNS entries for machines that it is providing leases to. Your machine is seeing an old/cached entry.

Alternatively, whilst I would not usually recommend for servers, you may want to enable dhcp - but put a reservation on its mac address in to your router.

share|improve this answer
    
I've tried rebooting everything in the house: The server, router, cable modem, all clients. Also, please see the update comment to my original post -- my workaround isn't working around. –  AndrewCr Oct 3 '09 at 19:28
1  
Sorry, I missed the part where you said that other machines do not have a problem. All I can really say is try disabling your Vista machine's firewall and possibly check that network location is set to home/private and not work/public (so all the services/sharing is on). If this does not work, I don't think I can help without seeing it :( –  William Hilsum Oct 3 '09 at 19:52
    
Do you know how it's supposed to work? Does WHS set up a local DNS server, or is it using netbios or WINS or something? Is there a tool I can run on one of the working clients that can tell me what mechanism they're using to resolve the name? –  AndrewCr Oct 3 '09 at 20:17
    
Since it is running on a 2008 base, I doubt it will Wins/Netbios as these are pretty much phased out. I do not know if it has the DNS/DHCP role pre-installed, If you can get on the machine, I would take a look if it is installed, if it is, use that instead of the router. You can try "ipconfig /all" from all machines & make sure the DHCP server field is the same to check they are all coming from the router. However, all that being said, if you have done what I said in the previous comment, I don't think I can really help you any further.. but if you provide more information, I will try my best! –  William Hilsum Oct 3 '09 at 20:48
add comment

I've seen this too, I gave up and put an entry in the hosts file (C:\WINDOWS\system32\drivers\etc\hosts)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.