Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm at my wits end with this, I've tried connecting to my samba server with smbusr, and smbusr_RO from windows 7 by mapping a drive. It says S:\ is not accessible, access denied. I know I'm putting the correct password in, for both users. I've even tried logging in as root, still no luck.

Here is my smb.conf file:

http://pastebin.com/cUGEF3yi

If you guys need more information just ask, thanks a million.

share|improve this question
    
Did you run smbpass -a <user> as well? That one catches me out every time I set samba up. – Xyon Nov 12 '12 at 12:35
    
I figured it out eventually, it was the underlying linux permissions. I had to 'chmod 777 /samba' which really bothers me, because now I'm worried my stuff is wide open. – Scriptonaut Nov 12 '12 at 21:00
    
Mnh, you can always force a uid+gid in the mount options and have directories 0770 and files 0660 (find -exec chmod works nicely there) – Xyon Nov 12 '12 at 21:14

You must log in to answer this question.

Browse other questions tagged .