Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When opening a new window in IE8 or IE9 (doesn't matter if using a link or window.open), my selected keyboard language is changing to English (doesn't matter what was the previous selection, tried it with a few different languages).

This doesn't happen for me in Chrome or Firefox (all the browsers are installed in their English version), and I tested it in Windows 7 and Windows 2008R2.

  1. Is there any way to avoid that?
  2. If there isn't - supposing the new window is within my website or application, is there a way to change it back?
share|improve this question

1 Answer 1

up vote 1 down vote accepted

It seems that IE honors the settings for default keyboard setup, as set in Windows. If you right-click the language icon in the bottom bar of the screen and select Settings, you can see (and modify) this default setting. Note that in those settings, you can also define keyboard shortcuts for changing the setup. (I regularly use Ctrl+number shortcuts to switch between Latin, Cyrillic, Greek, and other writing systems.)

This is a user setting. I’m pretty sure you cannot set it as a web site author for your site. I expect the answer to be the same for browser-based applications.

And this is fine if you ask me. I don’t expect a website author or an application programmer to know which keyboard setup I prefer, or the physical keyboard I’m using. I am quite happy with my Finnish standard keyboard setup that lets me type a large variety of languages (including English with “smart” punctuation) much more comfortably than e.g. using US keyboard setup, which is very limited.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.