Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I create a new host only network adapter, it will not set the IP address I assign to it. After I save the IP address & netmask it looks like it works (I see the Windows 7 User Account Control verification box), but the IP address doesn't get stored on the adapter.

I have tried adding/removing the adapter from within virtualbox and settings the values manually in the Windows aapter settings dialogue.

I am using a Windows 7 host.

Does anyone know why the settings don't get saved, or how to get more information?

C:\Program Files\Oracle\VirtualBox>VBoxManage list hostonlyifs
Name:            VirtualBox Host-Only Ethernet Adapter
GUID:            1721835e-e2c8-4f52-90fe-df7227ebe037
DHCP:            Disabled
IPAddress:       0.0.0.0
NetworkMask:     0.0.0.0
IPV6Address:
IPV6NetworkMaskPrefixLength: 0
HardwareAddress: 00:00:00:00:00:00
MediumType:      Unknown
Status:          Unknown
VBoxNetworkName: HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter
share|improve this question

2 Answers 2

From what you've said in your question, it looks like you are trying to configure your interface using the standard Windows network configuration dialogs. You need to set the IP address using the VBoxManage tool:

VBoxManage hostonlyif ipconfig "VirtualBox Host-Only Ethernet Adapter" --ip XX.XX.XX.XX --netmask 255.255.255.0
share|improve this answer
    
This was the answer for me. I couldn't figure out why my Windows host wasn't able to access the web server on the host-only IP of my Linux guest, but when I set the IP of the host-only adapter to an IP in the subnet that the Linux guest reported, all was well. –  denaje Jan 10 '13 at 17:01
up vote 2 down vote accepted

I fixed it!

All I had to do was disable "Network Activity Hook lightweight filter driver" in the adapter properties.

I don't know why disabling this made it work, nor what that driver is meant to do, but my VM is up and running again.

https://forums.virtualbox.org/download/file.php?id=7883

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.