Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop (a Sony Vaio on Windows 8) disables my touchpad when I "type". This means actually typing, or just holding down a key like say, W, A, S or D. The touchpad stays disabled for a short period (<1s), after releasing all keys. Naturally, I want to turn this feature off.
The touchpad uses a Synaptics driver, but I can't find a setting anywhere to enable the touchpad when typing.
I found values that allude to this functionality in the registry (e.g. HKEY_CURRENT_USER\Software\Synaptics\SynTP\TouchPadPS2\ZoneManager\TPTyping - Enabled), but their value is always 0, so I reckon it must be coming from somewhere else.
I've tried reducing the touchpad's sensitivity, as I read somewhere that there that certain values might secretly activate the "palm detection" functionality, which in turn secretly activates the "disable then you type" functionality, but to no avail. (Yes, I already went quite deep into the rabbit hole.)

Edit 14-11-12: I've updated the Synaptics driver using the one from the Synaptics site, but I still don't have a setting to enable the touchpad whilst typing. (Neither do I have the "PalmCheck" settings.)

Edit 27-11-12: I've gone back to the original driver, as the generic one had too many issues for my liking. This version doesn't have PalmCheck either, but like the generic one, it does have something called "SmartSense". Apart from the name, it looks like PalmCheck. Turning it off however, did not solve the problem.

enter image description here

share|improve this question
    
Linked: superuser.com/questions/658095/… –  stigok Nov 22 at 3:29

6 Answers 6

This is called PalmCheck. To disable this, go to Mouse Properties in Control Panel, select the Device Settings tab, select the Synaptics Clickpad or similar device in the list and click Settings, and under PalmCheck in PalmCheck-Enhanced, drag the slider down towards Off.

Synaptics Touchpad settings in Mouse Properties PalmCheck menu in Synaptics settings dialog

share|improve this answer
    
I've looked for this setting as well, but my Synaptics properties window doesn't have it. It does say "V1.4" instead of "V7.4", but according to Windows my driver is up to date. :/ –  Protector one Nov 12 '12 at 13:16
    
Check Synaptics' website (or your computer manufacturer's) for updated drivers. Windows only concerns itself with drivers that are available at Windows Update. –  Joey Nov 12 '12 at 13:21
    
The manufacturer's website provided me with an installer that resulted in the exact same driver. (Did require a reboot first, though. O_O) I'll try the generic touchpad driver from Synaptics if no one else has other suggestions. –  Protector one Nov 12 '12 at 13:43
1  
@Protectorone: As Synaptics suggests, set a restore point before installing the reference driver. –  DragonLord Nov 13 '12 at 4:51
up vote 4 down vote accepted

Since disabling SmartSense didn't solve the problem for me, I had to go all Morpheus on this hole. (Popped both blue and red.)
After much toil and bickering with various forms of Sony's Support, I gave up and tried messing with the Registry. After some failed attempts to disable the Synaptics filter driver that's attached to the keyboard, I found something that worked.

Solution:
In the Registry, go to the key HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults, and set the value of all string entries of the form PalmKms…, to 0. (Of course, they probably don't all need to be 0, but have fun finding out which one(s) you actually need!)
These values determine the amount of ms that the touchpad stays disabled after keyboard input has been detected.

I think Sony will probably issue an update to the VAIO Control Center where you can simply disable this functionality, but until that day, this fixes the issue.

share|improve this answer
    
Thanks! This worked! I never accidentally touch the touchpad while typing anyways, so I need the touchpad to work for things like Gimp where you scroll the canvas around by holding spacebar and moving the mouse pointer at the same time. –  trusktr Dec 13 '13 at 21:40

I have the exact same problem. had. I cannot seem to find the PalmCheck function mentioned above, neither can I find the PalmKms string entries in the Registry, I did find an easier way though.

Simply go to the properties window for your Synaptics Touch Pad Device Settings (instructions above) go to: Pointing->Sensitivity->Touch Checkng

The setting in this determines how long it disables the touchpad after using the keyboard. If set to the minimum (full left), it will disable the delay.

share|improve this answer
    
hey andrew, the delay was gone, but some other type of delay persist, try this and tell me if it happens to you too: Press "1" on keyboard then do left click on touchpad button, there is a delay for you?? (( for me, there is a 1 second delay to get left click working, it doesn't happen to right click ))... i have windows 8.1 –  iim.hlk Nov 12 '13 at 9:00
    
i solved this, there is a windows 8 setting that you should disable: press WIN + W, the type "mouse", search for a option named "mouse and touch panel config", then search a setting related to touchpad delay and deactivate –  iim.hlk Nov 12 '13 at 9:31

In Windows 8 the option is called SmartSense. Disabling this worked for me.

  1. Press Win+W to bring up Settings Search
  2. Type "synaptic"
  3. Double Click "SmartSense"
  4. Slide the Slider all the way to "Off"
  5. Click "Close" and then "OK"

This will Disable the Anti-Palm detection which prevents simultaneous Keyboard and Mouse use. I recommend you re-enable this feature when you're not gaming as otherwise you risk problems while typing.

share|improve this answer

For certain Elan "smart pads", you need to set the registry key values DisableWhenType_Enable and DisableWhenType_DelayTime_Move in HKEY_CURRENT_USER\Software\Elantech\SmartPad\, to 0 with Regedit.
A reboot is not required, but you might need to go into the mouse settings panel, and toggle a setting, so you can click Apply. This will cause the touchpad driver to reload the settings from the registry.

share|improve this answer

Apparently, there are different settings that can be set within the new Windows 8 metro-style settings page. The source article also covers how to apply a registry fix which will apply this setting to all local users. I don't know how this affects any driver software settings that came with the device, however.

  1. Swipe in from the right edge of the screen, tap Settings, and then tap Change PC settings. Or, if you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, click Settings, and then click Change PC settings.
  2. Tap or click PC and devices.
  3. Tap or click Mouse and touchpad.
  4. Under the To help prevent the cursor from accidentally moving while you type, change the delay before clicks work drop-down list, select No delay (always on).

Source: Button clicks for internal touchpads and pointing sticks are not responsive while or shortly after the keyboard is used

share|improve this answer

protected by Community Aug 29 '13 at 15:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.