Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP dv6 laptop with an an AMD Radeon 7690m XT dedicated Graphics card. The PC came with windows 7 but I recently upgraded to win 8.

I updated the drivers to the most recent Catalyst directly from AMD (HP simply does NOT provide graphic drivers for win 8), and the card seems to work fine, although it now reports as a Radeon HD 6700M series. That is OK since I read the Catalyst drivers just do that because the 7690m is just a custom version of a 6770 made by HP. that is not an issue.

The problem is that some games and windows itself seem to sometimes only "see" the integrated card (intel HD graphics 3000) instead of the dedicated GPU, for example, the direct X diagnostic tool, shows only the intel. The same when i see the properties of my display (in "advanced" under "display resolution" options.)

When i check device manager, i DO see both cards, also when I use GPU-Z, but why some applications seem to only see the intel one instead of the dedicated one?

I already changed an option in my BIOS and changed the "dynamic" setting, to "fixed", and that is supposed to make precisely what I want, that is, to make windows only see the dedicated card all the time, instead of switching cards depending in the application.

In fact, that option worked just fine under win 7, but now in win 8.

So, is there a way of making windows IGNORE the integrated card and just to care about the dedicated one? I tried disabling the intel card under device manager, but that only makes windows reporting a "microsoft basic display driver" under Direct X diag, instead of reporting the dedicated AMD card, which otherwise, the device manager reports working just ok (and with no driver issues).

Any ideas? Anyone has had this same probem under windows 8 with amd cards for laptops?

share|improve this question
    
I already tried both, the BIOS is already set to "fixed" so it should only use the dedicated GPU all the time, but windows still reports the integrated one. And i already tried disabling it under device manager, no effect either (and I already have mentioned both those possible solutions in the question). –  DiegoDD Nov 12 '12 at 19:41

4 Answers 4

In Windows 8, try this:

  1. Open the charms bar
  2. Select "Devices"
  3. Select "Second screen"
  4. Select "Duplicate"

This should make sure that Windows and programs will always be displaying the same thing on both outputs. This would obviate the need to disable one of them.

share|improve this answer
2  
The OP does NOT asked about extending or duplicating screens. What he wanted is to disable the GPU switching feature –  Lưu Vĩnh Phúc Aug 31 '13 at 7:09

I also had the same problem of switching graphics...then i discovered that when i right click on my desktop it showed configure switchable graphix options then i came to know that dedicated graphics card has to be assigned to specific games to run them on dedicated graphix...i also had a problem that games were not widescreen but i solved it by seeing a video on youtube! and when i ran BF3 without configuring it graphix it lagged like hell but not a single lag when i assigned high performance. So, there is nothing like you need to configure it in bios or upgrading driver....in my laptop it already had the option of configuring switchable graphix i didn't downloaded any drivers from anywhere.......some people say that when they assign games to high performance then also the game didnt used the graphix...first way- try running it on integrated graphix then on dedicated one...second way- when your laptop plays game on dedicated graphix the laptop will produce more heat and you will be able to listen your laptops fan sound as the dedicated graphix will produce more heat and fan will switch on cooling.... my driver versions AMD radeon hd 8670m - 12.105.9.0 intel hd 4000 - 9.18.10.3224 my laptop HP Pavilion 15-n011TX 3 gen core i3 4 gb ram 500 hdd 2 gb graphix windows 8

share|improve this answer

I know this isn't what you want to hear, but it's a driver issue. The Catalyst drivers don't know what to do with the custom "hybrid" 7690, so you get broken behavior.

From what I understand, Windows 7 and Windows 8 drivers are interchangeable. I would try removing Catalyst and installing the Win7 driver off HP's website.

share|improve this answer
    
thanks, but I've tried that option, and no, official HP drivers for win 7 do NOT work well with windows 8. However, installing drivers from AMD (instead of HP) seems to work better. in fact, there are even unofficial AMD drivers, called leschat , which seem to work even better than official ones, specially for laptops with windows 8 and unofficial support from the manufacturer, in this case HP. Thanks anyway –  DiegoDD Dec 1 '12 at 6:45

I'm coming in way late, but I have a similar HP laptop, and was looking for a similar solution. Maybe this will help another person stumbling in from a google hit.

If you go into the advanced bios settings on the HP DV6/7 (after you hit f10 to get into BIOS, press A repeatedly and you'll see the advanced column added to the options).

Since it's a dead thread I'll give the general place to look - here's the first disclaimer I've ever written:

A serious warning here: Even if you consider yourself really knowledgeable with modern PCs - don't get all cocky and starting messing around in here. It's pretty much a guarantee you don't know what a good # of the settings do, and the phrasing used by HP DE's doesn't let google help you much. Hp holds this stuff pretty tight. The unlocked section doesn't contain too many brutal ones, but more than any normal bios. I was surprised - I usually only see this low level stuff on non-consumer stuff.

Deep in the bowels of the new 'advanced' bios column is an embedded video section (lots of discrete card stuff as well). You can 'hard' disable the intel integrated chip here - just a on/off selection. But it's not that easy (just assume I didn't follow my own advice here). If you change that and reboot you're in trouble - it will disable all video from any card / interface. Dead. You can receover through multiple iterations of bios clear and reboots. - the setting isn't stored in the bios memory directly, so it's a downstream clear,

So long story short - you need to disable the intel card, then reconfigure some basic stuff such that the system, in every case, looks to the discrete card for video (and don't forget audio - like hdmi).

I hope it gets someone on the right track, or at least A track- then you can look through stuff some reference materials and figure out all the right knobs to turn. You might get lucky and it works on the first try.

Cheers

(whats that echo?)

share|improve this answer
    
well, a bit late indeed but somehow useful! I'll try those advanced settings some time. And if you get a better solution, e.g. getting custom drivers (like Leshcat's) be sure to tell! Thanks –  DiegoDD Sep 1 '13 at 4:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.