Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The installable binary that Evince provides does not provide me with the option to select a location I would like it to be installed to. Instead I came across a suggestion at https://mail.gnome.org/archives/evince-list/2012-April/msg00022.html which provides a possible solution however each time I have tried it I simply get the window that displays the options provided by the command msiexec.

The command I am running is msiexec.exe /i /qr "C:\Temp\apps\evince-2.32.0.145.msi" APPLICATIONFOLDER="C:\Program Files (x86)\Evince"

I am running Windows 7 Professional as local administrator and I am using the PowerShell to run the command.

share|improve this question
    
Switch /qr and /i. i parameter must be right before path to file. –  week Nov 12 '12 at 19:33
    
@week - I did try that and it still doesn't work. –  PeanutsMonkey Nov 12 '12 at 19:57

3 Answers 3

up vote 2 down vote accepted

Ok, I tried just now on Windows 7 64bit.

  1. Run cmd.exe as Administrator / eg. create shortcut on desktop for cmd.exe and click right mouse button and select run as Administrator
  2. cd to folder with installator
  3. msiexec /qn /i evince-2.32.0.145.msi APPLICATIONFOLDER="c:\program files (x86)\Evince"

If you want a setup dialog, just for confirmation, no settings there, instead of \qn type \qr. If something is not working try adding msiexec /qn /l* evince_install.log /i ..., that will help you solve problems and show another parameters which you can manually assign.

share|improve this answer
    
That worked. Question though. Why do I need to run cmd as an Administrator? Why can't I use the PowerShell? –  PeanutsMonkey Nov 12 '12 at 20:45
    
I also noticed that if I attempt to uninstall the application, it removes it from the list of installed applications however does not delete the files in the directory. –  PeanutsMonkey Nov 12 '12 at 20:56
    
You can use powershell, but powershell has a distinct semantics. Those " and ( aren't good. You shouldn't run directly msiexec, but use something like i-think22.net/archives/2011/02/06/… or invoke-expression.. but I'm not into powershell so I don't know exactly.. –  week Nov 12 '12 at 21:02

The evince msi installer has the option to select the install location. Just hit the 'Advanced' button in the opening screen.

share|improve this answer

It still does not work on Windows 8 ... I've been working on it for a few hours and it seems there is no issue reporting but when I go to the Program Files (x86) or whatever folder I place it in it just happens to be missing (every time!).

I'm getting frustrated because I'm trying to review my technical papers compiled with PDFlatex ... is there any other software on mingw or any third party?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.