Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a standard Win 7 account 'popuser' to which I'd like to grant start and stop permissions for the OpenVPNService. I've used the following command successfully on other machines, but for some reason on a new Acer Aspire 5830T that I'm setting up this doesn't do the trick for me:

subinacl /service OpenVPNService /grant=popuser=TO

I keep getting the following error message:

LookupAccountName : OpenVPNService:popuser 1337 The security ID structure is invalid.

Current object OpenVPNService will not be processed

Elapsed Time: 00 00:00:00
Done: 0, Modified 0, Failed 0, Syntax errors 1
Last Syntax Error:WARNING : /grant=popuser=to : Error when checking arguments - OpenVPNService

I've tried adding the machine name to the username and the service name to no avail. I'm running command prompt as an administrator.

Anyone have any ideas what's going on?

share|improve this question

1 Answer 1

The problem was that my 'popuser' account had originally been created with another name and then was renamed to popuser. subinacl did not recognize the new name as an account. I deleted and added the account properly and now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.