Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linux-based file server at home which I access from my Windows machine through SMB. I have been running Windows 8 Consumer Preview for ~6 months straight without any issues.

I've recently upgraded to the Windows 8 RTM (Pro), and now performance has gone from stellar to abysmal. I am experiencing extreme loss of speed (previously able to stream high resolution video, now has trouble keeping up with loading small audio files), as well as sporadic loss of connection.

Update: After doing some more research, it seems the issue is that my network connection is capped at ~10mbit downstream. I am using the builtin RealTech gigabit ethernet adapter with a Cat5 cable and a Netgear gigabit router. What in the Windows software could cause this cap, and how would I go about fixing it?

share|improve this question
1  
1) is your NIC is full-duplex at wirespeed? sometimes it can get confused. 2) do you have a homegroup established on that network connection 3) have you tried disabling IPv6 if you don't use it? –  Frank Thomas Nov 13 '12 at 0:52
    
1) It was set to automatic negotiation, but is now full-duplex at wirespeed. 2) I have not set up a homegroup. It has worked perfectly without under both Win7 and Win8 CP. 3) I tried disabling IPv6. - The problem still remains. –  evilcandybag Nov 13 '12 at 15:03
1  
have you tried upgrading your nic drivers? My Intel nic runs much better with the intel drivers than the MS Update drivers. Chipset drivers are also related to good NIC functioning. I'm just mentioning these because you have to install them on every build and if they were forgotten on this build, that would explain your regression. –  Frank Thomas Nov 13 '12 at 18:44
    
Thank you for your help. I have updated the NIC and chipset drivers. That did not help. I also did some more research, and discovered that the issue is that bandwidth is capped at 10mbit. I have updated the question to reflect this. –  evilcandybag Nov 13 '12 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.