Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell XPS Laptop (l501x). I have replaced the original Seagate 500GB hard drive with an SSD Intel 320 120GB when I first purchased it a year ago. It's been working great. The laptop is booting in about 23 seconds, so the SSD is great. I have an Acronis image created that I came back to every three months just to keep everything clean.

The SSD is partitioned with one logical drive for my data. So, recently I thought since I am not using my optical drive often enough to swap it out with a HDD caddy and add my seagate 500gb hard drive. I ordered the caddy placed the HDD in it and now load Windows. It just hangs on the screen that should show the Windows logo.

I have tried everything that I know and searched it online. I have uninstalled the SATA controller AHCI and let Windows install it. Still will not boot into windows.

I wanted to mention that the Seagate 500GB drive was the one that came with my laptop before I switched to the Intel SSD.

As you know Intel has this application called Intel Rapid Technology which loads once in a while and shows the second hard drive, but then, when I restart it hangs again and Windows will not load. As soon as I remove the HDD Caddy and restart it loads Windows fine.

I also formated the Seagate 500GB HDD in NTFS and still Windows will not load. When I go into the BIOS it shows the Fixed SSD and also "Sata ODD 500GB" instead of the optical drive but it will not boot into Windows when the HDD caddy is present.

There is nothing wrong with the caddy. I have another laptop (Asus) and I installed the HDD caddy and Windows 7 loads without any glitch. I don't get it.

I have also flashed the BIOS because Dell had a new version (A08).

I also wanted to add that I refreshed Disk Management and the Device Manager and the second drive does not display.

At this point I think it's a Windows issue so before I reinstall Windows 7 Home Premium from scratch I wanted to see if there was anything I was missing. Any advice would be greatly appreciated.

share|improve this question

2 Answers 2

Try a different hdd. Using the oem Seagate 500GB drive in a caddy didn't work in my L501x for me either. Something with spinup time or voltage I guess. There is a firmware update fix for the Seagate on Dell drivers and software page. The firmware update is easy, but I haven't tried the Seagate in the caddy since updating it. I have used a Samsung Spinpoint M8 1TB and that works fine for movies and I have swapped other ssd's in the caddy with no problems. (You didn't ask, but the xps won't boot from a caddy. If you want a dual boot, with a system on the main hdd and a second on the caddy, the main hdd must be the boot drive. If you image a second system on the caddy, after installing a dual boot second system, you'll need to run your install disk "startup repair" to fix the boot. googgle tutorials on sevenforums)

share|improve this answer

It is usually casued because either the hard drive is broken, or because the hard drive is unformatted.

Boot the laptop into Gparted Live (CD) with the non-appearing hard drive installed. If the drive appears in gparted live, simple create new partition tables and/or rebuilt the filesystem; apply changes, and then reboot the PC back into Windows. As long as the drive is not defective, it should now appear in Windows.

p.s. to troubleshoot whether it is an issue with the hard drive or not, I highly recommend trying a separate verified working hard drive into the caddy and seeing if it displays in Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.