Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like my virtual machines; I have both VirtualBox and VMware Workstation installed, and so my Windows 7 host has several virtual network adapters ("VirtualBox Host-Only Network," "VMware Network Adapter VMnet1," etc.) to support these.

My problem is that these adapters keep getting flagged by Windows as public networks and causing problems with my firewall and VPN connection. For example, at the moment, all of my virtual adapters are showing up as connected to "Unidentified network," which is a "Public network" with "No Internet access." Just because these network connections exist, the Windows Firewall has decided to start applying its public network rules everywhere, disallowing ping and Remote Desktop over my physical, wired, "Domain network" connection.

This isn't the first time I've had problems of this sort. How can I fix this (e.g., by telling Windows Firewall to ignore those additional networks when deciding public versus private versus domain, or by telling Windows Firewall to not apply public rules to a domain connection)? (I realize I can just relax my firewall rules for public networks, but that seems undesirable.)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This site has instructions on how to fix this problem by instructing Windows to ignore the virtual network adapters for the purposes of network location awareness.

A brief version of the instructions from that site:

  1. Within PowerShell, run get-wmiobject win32_networkadapter to get the DeviceID of each affected adapter.
  2. Open the Registry Editor and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}.
  3. Adapters are organized in subkeys by DeviceID. For each affected adapter, add a DWORD value named *NdisDeviceType (note the *) with a value of 1.
  4. Reboot.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.