Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

how to prevent "you'll need to provide administrator premission to copy to this folder" message

when i try to copy or delete file from c:\ in Windows-8 ?

i have administrator user and i try to give full control to c:\

thanks

share|improve this question
1  
The best way is not to attempt to delete or copy into this directory but use the apporiate profile directories. –  Ramhound Nov 13 '12 at 15:47

2 Answers 2

Windows is asking you for administrator rights because only an administrator has the right to copy or delete files in that directory.

For security reasons, it is best to not copy or delete files into that directory.

But if you really must, You can edit the permissions in that directory to allow non-administrator access. But make sure to NOT make those non-administrator rights inheritable because that would expose all sub-directories to security risks.

In your specific situation, this is how you do it:

  1. open properties of C:\ by right clicking the directory then selecting "properties"
  2. go to "security" tab
  3. click "advanced"
  4. click "change permissions"
  5. click "add"
  6. type in the name of your user account and press enter
  7. click "full control" checkbox
  8. change combo box to "this folder only"
  9. click ok and say yes to warnings
  10. click ok to finish
share|improve this answer

Disable UAC or set it to a lower level. Restart PC and then check.

Or you can open msconfig from Run menu - tools - Change UAC settings.

share|improve this answer
    
i try this, but still same problem –  Gold Nov 13 '12 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.