Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is, when I open applications I need to always right click, select run as admin.

enter image description here

When I don't do it getting unexpected application errors. BTW, I turned off UAC.

It's annoying. Is there any way to change behavior of double left-click to act as "Run as administrator" action? I mean to make "Run as administrator" action by default. Thx in advance

share|improve this question
    
Did you rebooted after turn off UAC? –  avirk Nov 13 '12 at 17:04
    
@Ramhound Turning off UAC doesn't help in Windows 8, for files which are run from the Program Files (x86)-directory and possibly others. –  Aske B. Sep 30 '13 at 17:08
    
@Ramhound I found this problem today with the application "Notepad++". When I open files it doesn't run the program as administrator. I had to go to the directory of Notepad++ and open it as admin, and then open the file there. This problem never occured for me before I got Windows 8. All programs were run as admin by default when UAC was off, in Windows 7, to my experience. EDIT: and I needed the admin rights because I couldn't save the changes because it claimed the file was open in another program. –  Aske B. Sep 30 '13 at 17:19
    
@Ramhound I'm no expert so I can't prove you wrong but I used Windows 7 for several years and never experienced problems, and I only got Windows 8 two weeks ago, so it was my first thought. Plus it keeps asking me for permission if I want to edit files in certain directories, which clued me things had changed, since I never experienced that on Windows 7, after turning UAC off, of course. –  Aske B. Sep 30 '13 at 17:27

6 Answers 6

up vote 33 down vote accepted

Method 1 (only works on shortcuts):

  1. Right-click the shortcut, click Properties.
  2. Click Advanced. Select Run as Administrator.

Method 2 (affects all shortcuts, and works on jump-lists and opening files with the application):

  1. Go to the location of the executable.
  2. Right click AppThatRequiresAdminRights.exe and select Troubleshoot compatibility.
  3. Select the option Troubleshoot program after the wizard has finished detecting issues.
  4. Choose the The program requires additional permissions option. The wizard will apply the Run as Administrator setting to AppThatRequiresAdminRights.exe program.
  5. Click Test the program (required) and close the wizard.

Found here

share|improve this answer

Use the good old Task scheduler trick which works since Vista.

Here is a tool which help you to do the steps:

http://freeavvarea.r00t.la/UACPass-en

share|improve this answer
    
I can get Task Scheduler to run my app but it does it in the background for non-admin users. I need the app's UI to be visible to any account. Is this possible? –  gonzobrains Jul 15 '13 at 19:08
    
no, the trick only works if your account is part of the admin group. –  magicandre1981 Jul 16 '13 at 3:59

Kill all Explorer instances and then start it again through Task Manager (Ctrl+Shift+Esc) with administrative rights.

share|improve this answer
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
shutdown -r -t 0 

entering on the PowerShell (started as administrator) did it for me without specifying something for every single application.

Please note that this does permanently disable UAC. Dragging the slider down in the UAC settings will not disable the UAC completely, it just won't prompt anymore but still remains active.

share|improve this answer
    
By definition this just removes the prompt; EnableLUA specifies whether Windows® User Account Controls (UAC) notifies the user when programs try to make changes to the computer. UAC was formerly known as Limited User Account (LUA). –  Michael Perrenoud Sep 9 at 16:12
    
@MichaelPerrenoud It completely disables UAC, you should try it at least before voting down. Btw: Prompt will be disabled when you take the slider down to the min value. –  Mostey Sep 9 at 16:45
    
You know what, you're right my friend. I disabled UAC a much different way, through local groups, but when checked the registry key the value is in fact 0 now. Please edit your question so that I can up vote your answer. I'm sorry. –  Michael Perrenoud Sep 9 at 16:53
    
@MichaelPerrenoud No problem, which question do you mean? I never asked one. –  Mostey Sep 9 at 19:44
1  
I meant to say edit your answer with something more and I can change my vote. –  Michael Perrenoud Sep 9 at 19:45

Search for CMD in start menu and run it as administrator and enter the following command.

net user administrator /active:yes

share|improve this answer

I wrote a simple tool to solve this problem. Please find my article here.

share|improve this answer
    
It is generally preferred that answers be more complete instead of relying totally on another website, which can move or go down unexpectedly. If possible copy your answer from that site here. –  Heptite Jul 12 at 8:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.