Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The computer was built in 2010 and has been operating just fine since then. The ethernet port had been questionable before as it would require a re-plug into the machine or switch maybe once or twice a year for some sort of "jumpstart" effect.

The computer was left in Windows 7 "sleep" mode for a duration of approximately 12 hours since it last functioned correctly and was set to sleep. No abnormal user operations before issue. No network connectivity modification prior to issue. No power source conflicts. No changes to the network. No other devices on same local network reporting failure. No driver errors reported by Device Manager. No changes to issue when using different ports on the LAN switch box. Different CAT cable did not help. Reboot did not help. Safe mode with networking did not help. And weirdest of all, it works absolutely fine with a Linux Live CD's NIC driver set (no errors detecting hardware or network or connecting to network).

The card is a 'Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)' and is an embedded NIC on a GIGABYTE G41M-ES2L motherboard. Device Manager: "This device is working properly". Using a Microsoft provided and signed driver version 7.2.1127.2008 dated 2/26/2008. As I said, it's been working fine all this time.

Briefly: Windows 7 no longer can detect ethernet network, but has working hardware and drivers and two years of functioning history. Ideas~ go!

share|improve this question
    
It sounds like port is not functioning, if Windows doesn't even see the device, time to buy a non-integrated network card. –  Ramhound Nov 13 '12 at 18:17
    
Port is functioning. Windows does see the device. Please read before commenting. :( –  kris Nov 13 '12 at 19:13

1 Answer 1

Windows does this little thing on the network card configuration screen wherin it asks to allow windows to shut off the NIC when it has not been used in several hours. By default this feature (or not) is enabled by default. I have never seen a windows machine recover from that without a power reset. It uses a bit more power (milliwatts more) but I always turn that option OFF. Saved me many a heartache. If that does not get it, try installing a NIC card and disable the oboard NIC. Hint- now might be the time to add a Gigabit card if you ever wanted one. Don't forget to disable the auto power off on the NIC windows setting like we did before. I imagine that will fix it but if it does not , we probably ruled out a bad internal NIC. And now we have a spare card for testing later. I try to stock a couple just in case. This is Illinois and some of our thunderstoms can cause NIC failures.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.