Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There's some keyboard device that attempts to pair with my iMac about every 30 seconds. The reject button only removes it temporarily. Same with the disconnect. Discoverable is already off for the bluetooth.

The window is modal and breaks my workflow every few seconds and I can't put it on a separate screen since it closes and reopens every few seconds. I can't just turn my bluetooth off since I have a mouse connected. I seems like Apple built in a pretty powerful way to 'undefendably' sabotage a computer.

Is there a way I can permanently 'ban' a Bluetooth address?

share|improve this question
    
Do you know what the device is? What happens when you just pair the device? –  Ramhound Nov 13 '12 at 19:37
    
nop, don't think it's actually in our office so I can't type in the keys to pair it –  Xster Nov 13 '12 at 19:42
    
I managed to find the keyboard that was causing this but I would like to know if there is a way to permanently reject a bluetooth request. –  Charles Beattie Feb 11 '13 at 16:01
    
Seems to be a really old issue across different OS X versions, with no proper fix yet. Showing modal dialogs repeatedly with no way to opt out is just stupid. (Edit: Perhaps Amyunimus has found a solution...) –  Karan Feb 18 '13 at 5:55
2  
Bug submitted to apple. –  Charles Beattie Feb 20 '13 at 16:01

7 Answers 7

up vote 1 down vote accepted

To answer your question: No, not without hacking blued.

share|improve this answer

I found a way to work around this: (inspired by this question http://superuser.com/a/497193/10009)

Assumptions:

The offending keyboard previously was paired with this computer, therefore the computer 'remembers' the device.

Caveat:

This involves modifying system settings files so be careful.

Steps:

  1. Find the Bluetooth address of the offending device and write it down. (Shows up in the System Preferences -> Bluetooth window when the pairing request is happening)
  2. Turn off bluetooth (System Preferences -> Bluetooth)
  3. Back up your /Library/Preferences/com.apple.Bluetooth.plist , and ~/Library/Preferences/com.apple.Bluetooth.plist files. (You'll need sudo for the first one)

  4. Because the plist files are in binary format you'll need to convert them to xml: plutil -convert xml1 com.apple.Bluetooth.plist

  5. Edit the converted plist files in a text editor.

    1. Find the (lowercase) bluetooth address in the file. It should be in a <key></key> tag.
    2. Delete the <key>...</key> tag and the immediately following <dict>...</dict> key.
  6. Save the text file and convert it back to binary: fplutil -convert binary1 com.apple.Bluetooth.plist

  7. Repeat for both locations of the file.

  8. Restart Bluetooth
share|improve this answer

While the pairing request is still showing on your screen:

  1. Press and hold the Option key, and then click the bluetooth icon in the top bar.
  2. In the submenu for the offending device apart from Disconnect, you will now see an additional option - Remove.
  3. Click Remove.
share|improve this answer
    
this worked for me...finally –  Francesco Oct 18 at 23:15

This helped me:

Go to System Preferences -> Bluetooth, unclick Discoverable.

The add your mouse as a favorite on the devices panel.

Finally - go to the Sharing Setup, make sure file transfer, file exchage and PDA sync services are off. (as long as you don't use any of those yourself.) and check the Require pairing box on all.

Note: This is from a while ago-- I've tried to update it for newer OS, but it may not be implementable in mountain lion.

share|improve this answer
    
OS X 10.9.1 does not have this option. –  ViliusK Jan 28 at 18:36
    
FYI, the discoverability status can quickly be checked by holding down the Option (Alt) key and then clicking the Bluetooth icon in the top tray. –  ccpizza Oct 22 at 8:09

Was enough to:

  • sudo plutil -convert xml1 /Library/Preferences/com.apple.Bluetooth.plist
  • Searched for the name of bluetooth device and removed both <key>...</key> and <dict>...</dict> XML elements.
  • sudo plutil -convert binary1 /Library/Preferences/com.apple.Bluetooth.plist
share|improve this answer
    
It's easier to just delete the file, i.e. sudo rm /Library/Preferences/com.apple.Bluetooth.plist –  ccpizza Oct 22 at 8:06

Also you can just:

  • Reconnect that wireless keyboard again. You'll need to type those digits, which shows up on screen.
  • Choose Remove (not Disconnect!). Then you'll be informed, that you'll have to pair those devices again if you'll want to use it.

That's the way how to disconnect wireless keyboard permanently.

share|improve this answer

Just had the same problem. One of the office keyboard kept asking to pair with one of the iMac which has never been paired with that keyboard. It had a very low batteries. Once the batteries has been replaced problem stopped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.