Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Dimension e510 computer, with on-board video (disabled). I also have a Nvidia FX 5200 PCI card that I installed after the fact. I had to do some searching to even get Ubuntu 9.04 to install on this (disable acpi i think). Now I got that running, and the machine is using the nvidia-glx-173 drivers.

My configuration auto-detects my Samsung monitor just fine, but auto-detects the resolution incorrectly. It sets the resolution to 1600x1200, when it should be 1920x1200. I need to get my resolution to be 1920x1200.

I have 3 machines connected through a KVM (USB/DVI) switch and my other Ubuntu detects the display correctly, and my windows detects the displays correctly.

I have tried:

  • executing dpkg-reconfigure -phigh xserver-xorg
  • running nvidia-xconfig (sets the resolution to 1024x768 or 1600x1200)
  • using nvidia-glx-new and nvidia-glx-180
  • manually configuraing /etc/X11/xorg.conf in a variety of settings. They almost always seem to get ignored.

I have seen online that Ubuntu has issues with PCI cards and on-board video. I've also seen specific issues with the FX5200 and needing nvidia-glx-173 drivers. So it seems as if i have a perfect storm of issues with this machine's configuration.

Can anyone suggest something specific i can do to try to fix this? I've tried just about everything I could find on the ubuntu forums.


UPDATE: I have connected the monitor directly, and there is no change in how it acts. I also tried to upgrade to nvidia-glx-180 (again) and still no dice..


Here's what i have in my xorg.conf now.

Section "Monitor"
    Identifier	"Configured Monitor"
EndSection

Section "Screen"
    Identifier	"Default Screen"
    Monitor		"Configured Monitor"
    Device		"Configured Video Device"
    DefaultDepth	24
EndSection

Section "Module"
    Load	"glx"
EndSection

Section "Device"
    Identifier	"Configured Video Device"
    Driver	"nvidia"
    Option	"NoLogo"	"True"
EndSection
share|improve this question
    
Does it get it right when connecting to the monitor directly rather than through the KVM? Does the screen model/manufacturer appear correctly in gnome-display-properties? –  bobince Oct 4 '09 at 1:04
    
@bobince - i really didn't want to connect the monitor directly, as i had to undo a lot of wiring and i wouldn't have wanted to do it each time i boot. Anyway, when i connected it directly and rebooted, it still didn't detect it. –  Roy Rico Oct 4 '09 at 1:53

2 Answers 2

Here's a blog post on setting up custom resolutions, if the driver refuses to co-operate.

share|improve this answer

At 1920x1200 the video card will struggle to handle full-screen video and probably even dragging a window with many icons.

However, if you really want to set it, you can download the nvidia-settings package and use the GUI Control Panel to set it.

If you'd like to set it manually, change your /etc/X11/xorg.conf to:

Section "Monitor"
    Identifier  "Configured Monitor"
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Monitor             "Configured Monitor"
    Device              "Configured Video Device"
    DefaultDepth        24
    SubSection "Display"
        Depth   24
        Modes   "1920x1200"
    EndSubSecetion
EndSection

Section "Module"
    Load        "glx"
EndSection

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "nvidia"
    Option      "NoLogo"        "True"
EndSection

The best suggestion I can give you though would be to buy an AGP or PCIe video card that's more powerful if the motherboard has one of those slots.

share|improve this answer
    
Unfortunately, the motherboard does not have these slots, it only has PCI. I'll try those settings. Thanks. –  Roy Rico Oct 3 '09 at 23:57
    
also, there's a typo (EndSubSection) –  Roy Rico Oct 3 '09 at 23:59
    
So this didn't work. Maybe 1920x1200 is too big for the memory? –  Roy Rico Oct 4 '09 at 0:05
    
Unlikely. The 5200 was a crap card but not that crap... ISTR it generally had 128MB, which is an order of magnitude more that you need for the screen buffer. –  bobince Oct 4 '09 at 1:00
    
I tried this configuration (with the typo fixed) and it still did not work. I tried upgrading to nvidia-glx-180 too, and that didn't work at all! –  Roy Rico Oct 4 '09 at 1:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.