Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a data volume which is mounted into C:\Data using a junction, and the drive has no letter mapping. When I delete a file from this drive, it gives me the delete permanently confirmation and does not use the recycle bin. This happens for all files, even those near the root with short filenames.

When I delete a file from the C: drive it does use the recycle bin.

I have checked the registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\IDE
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Controller0

and the only drive flagged as removable is my eSATA external drive. In addition there is a TreatAsInternalPort for each of the internal drives (my data volume is actually a RAID mirror).

When I check the recycler settings, it does have a size for both Data and System, which are the names of my drives as configured in Computer Management and the size is set for 20 GiB each.

When I check the hidden files/folders there is a $RECYCLE.BIN folder on the data drive.

So, how can I make Windows 7 use the recycle bin for my data? And specifically the recycle bin on that drive?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.