Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am planning of creating a application in Visual Sudio Pro 2012 in future. I want the app to run in XP, Vista, 7 and 8. So, does the app created in Visual Studio Pro will work on these OS or not?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If the application targets .Net 3.5 or 4.0, then it should be able to run on your desired operating systems (subject to having installed the framework), irrespective of the version of Windows on which it was developed. (Of course, you'd still want to test on all the platforms you're going to support)

share|improve this answer
    
You can target later versions of .NET - if you use something like ClickOnce installation it will check for and install the correct version of .NET for you. –  ChrisF Nov 14 '12 at 8:56
1  
Worth noting that 4.5 is only available for Windows Vista and later, so would not work for Windows XP –  Rowland Shaw Nov 14 '12 at 9:02
    
Good point, I'd forgotten that wrinkle. –  ChrisF Nov 14 '12 at 9:04
    
@Rowland Shaw Thanks for pointing out. –  user157242 Nov 14 '12 at 13:56
    
I think I can also use .Net 3.0 with Visual Studio 2012. Am I right. I'm asking just because I have never use VB.net earlier in my life –  user157242 Nov 14 '12 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.