Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Kinesis keyboard that I ideally like to use by placing it on top of my laptop. When I do that, I wind up pressing keys on the built-in keyboard with my external keyboard.

I've been playing around with the GUI keyboard controls and reading the ubuntu forums for a couple hours without really any forward progress. Even a hacky solution or a pointer to a good library for configuring multiple keyboards differently would be much appreciated.

thanks.

share|improve this question

migrated from stackoverflow.com Nov 14 '12 at 10:18

This question came from our site for professional and enthusiast programmers.

1 Answer 1

You can try adding

i8042.nokbd

to the GRUB boot line to disable access to the keyboard controller at boot.

It is possible to turn off the keyboard via 8042 commands without rebooting, but it's not really safe to do so; on some systems, this interferes with the memory management and causes a nasty system halt.

share|improve this answer
    
this is perfect for my situation, worked fine, though had a scary moment at login :) For anyone who happens on this post with the same question, I googled i8042 and found blog.yjl.im/2010/12/using-xinput-to-disable-keyboard-mouse.html which outlines a pretty good post-boot approach. –  David Nov 14 '12 at 9:34
    
An even harderware approach would be to use four stripes of Plast-Attach or any other type of cuttable adhesive plastic to build a keyboard holder under your Kinesis - two large strips to distance the keyboards, and two smaller strips to keep the Kinesis from slipping :-) –  lserni Nov 14 '12 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.