Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a VB6 app that has client and server installations that are created using Wise Installer 9. One key aspect is that we need to run the install in silent mode, so we have a file (InstallPath.ini) that tells Windows where to install. We have used this for years on Windows 2000 and Windows 2003 servers without issue, but now with Windows 2008 Server the install path is ignored and it defaults to Program Files (x86).

I have tried running the batch install using 'run as administrator' and it gives the same result. However, if I run the .exe itself, I am able to navigate to the desired directory and it will install where I want it. But this is not acceptable in the long run due to the number of servers we install on.

Is there a workaround for this? I have searched numerous forums, but have not found a solution. We can't be the only ones running silent installs on Windows 2008. It seems like it would be a Windows issue, since it appears to override the install path we are trying to use.

share|improve this question
1  
What code/mechanism is responsible for reading, parsing, and utilizing configuration from InstallPath.ini? That, I suspect, is where your real problem lies. –  Lynn Crumbling Nov 12 '12 at 18:44
    
The install is created by Wise Install 9. It includes the exe, InstallPath.ini, and a batch file that kicks off the install in silent mode. None of this has changed and in fact the exact same install works fine on Windows 2000/2003, just not 2008. To me, that indicates that the operating system is intervening and forcing it to go to Program Files (x86). I suspect there is a setting within Windows or Server Manager that can be turned off, but I can't seem to find it. –  Jeff Loomis Nov 13 '12 at 18:13
    
Is InstallPath.ini consumed by the batch file at install time, or the .exe at install time, or by Wise Install 9 at install-build time? –  Lynn Crumbling Nov 13 '12 at 19:44
    
Have you tried turning off UAC for the duration of the installation? –  Peter Hahndorf Nov 14 '12 at 12:43
    
You can also try to change the value for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir(x86‌​) just for the installation via script and then set it back afterwards. This way your custom location should be used by the installer. –  Peter Hahndorf Nov 14 '12 at 12:47
show 2 more comments

migrated from stackoverflow.com Nov 14 '12 at 12:16

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.