Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had this problem since 2.6.39: my computer won't boot without disabling hyperthreading in the bios. I'm using 3.6.6 now and still have the same problem. The only thing I can add to the description, that it hangs early in the boot process (processing udev).

I think it has to do with this bug, but it hasn't been updated since April. Any ideas?

Earlier kernels (<2.6.39) still boot fine with hyperthreading.

share|improve this question
Tell us about your hardware, particularly your motherboard and BIOS. Does the processor.nocst workaround solve it for you? –  David Schwartz Nov 14 '12 at 14:48
This is my ACPI dump with HT disabled in the BIOS (linux won't boot otherwise): –  user12932 Nov 14 '12 at 14:54
BIOS Information Vendor: Award Software International, Inc. Version: F1 Release Date: 08/04/2009 Address: 0xE0000 Runtime Size: 128 kB ROM Size: 2048 kB –  user12932 Nov 14 '12 at 14:56
Motherboard: Gigabyte P55-US3L –  user12932 Nov 14 '12 at 14:57
The processor.nocst workaround doesn't work for me. –  user12932 Nov 14 '12 at 14:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.