Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using VMware Player (4.0.4 build-744019) hosted in Windows 7 Pro, 64-bit to open a Windows XP Pro virtual machine. Lately, when I try to log on to Windows XP, I get the following Logon Message:

Windows cannot connect to the domain, either because the domain controller is down or otherwise unavailable, or because your computer account was not found. Please try again later. If this message continues to appear, contact your system administrator for assistance.

Eventually I am able to log on by changing the Virtual Machine's Network Adapter settings (from Bridged to NAT or vice-versa). Just waiting and retrying later by itself doesn't seem to work.

After changing the network adapter settings back and forth a few times (or many times), it finally log's me on, but it seems to be taking longer and longer to log on each day.

Any ideas on what could have changed (since this used to not happen) and how to fix this are greatly appreciated.

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

Short answer:

Your XP installation in the VM is connected to a domain and requires AD to authenticate.


Understandable answer:

Windows is usually configured in one of two ways:

  1. Standalone (workgroup). You log in as a user, which really means 'user' At this computer
  2. Part of a domain. The log-n screen now not only has a user and password field, but also a domain field. (you can expand or collapse that field. So you might not have noticed that before).

If your windows is part of a domain then it is usual to log in as user@domain, and this username and password are checked by the domain controller. It needs to be able to reach this domain controller, else it can not authenticate and you can not log in.


An additional confusing part here are cached logins.

if you are part of a domain you need to be connected to the domain to log in the first time. If you have no working connection (network) to the domain you simply can not log in. This is not practical for laptops, yet corporations do user both domains and laptops.

To help with this windows can remember that you logged in successfully before. If you have no network but try to log in with the same username and password it will still let you log in.

Somehow something went wrong and your cached credentials got lost.

The next time you tried to log in it had to connect to the domain controller to verify your password. It failed until you got the network settings right. After that worked again for the first time windows once more had cached credentials and it continued to work in both network modes.


it finally log's me on, but it seems to be taking longer and longer

I suspect it is trying to reach stuff on the network and you are getting time outs.

How long does it take if you log in with a local account? (Select the name of your computer in the third field and change username and password to an account you set up before).

share|improve this answer
add comment

Any chance another copy of the same VM is running elsewhere on the network? I had this happen to me after I copied my XP VM to another workstation. When I tried to log in to the VM on the second workstation while the VM was started and connected to the network on the original workstation, I got the message you show.

I solved by giving each copy of the VM a unique computer name. To do this, you will need a domain admin account that can leave/join your domain and a local (non-domain) admin account on your VM to initiate the comain leave and join.

Here're the steps that worked for me on an XP Pro SP3 virtual machine:

  1. Log in to the XP VM using a local Windows account with admin privileges.
  2. Click Start -> right click My Computer -> Properties
  3. Click the Computer Name tab
  4. Click the Change... button
  5. Type in a new unique Computer Name. Write down the full text that appears in the Domain text box in the "Member of" area. You'll need it later to rejoin the domain.
  6. Click the Workgroup radio button. Enter WORKGROUP (or any name, doesn't matter)
  7. Click OK. When prompted, enter the credentials of a domain admin account so that the computer can leave the domain.
  8. Click OK to get out. Restart the VM as prompted.
  9. This step is probably not necessary, but after I left the domain, our network administrator removed the original computer name from Active Directory.
  10. After the VM restarts, log back in with the local admin account. Get back to the Computer Name tab, verify that the computer name is the new name you entered earlier, click the Domain radio button, type in the domain name you recorded in Step 5, respond to the credentials prompt using the domain admin account again, restart and you should now be able to log in with your own domain credentials.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.