Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange Stuck Problem with VMware Fusion and Ubuntu 12.04 as Guest System.

On High Loaded process the System sticks with "Soft Lockup CPU Stuck" and I have to reboot the VM. The Same System via VirtualBox works fine but VirtualBox Performance is bad, especially I/O.

This happens if I use 2 CPU Cores. With only 1 CPU Core the VM under VMware Fusion works without any Problem. However, I need 2 Cores. Is there any fix for this?

share|improve this question
    
I'm not sure what a 'Stuck Problem' is, but I'm guessing you mean that your CPU usage is maximized. Unfortunately, I don't have an answer, but I am seeing a similar issue using VMWare Fusion 5.0.2 and Ubuntu Server 12.04. Originally, I set VMWare to give my VM four cores, but when it went down, it brought my host to 400% CPU usage*, so I tried two cores which eventually resulted in 200% CPU usage* and finally I've resorted to a single core which freezes and consumes 'only' 100% of my host CPU*. Help would be greatly appreciated.. * as indicated by Activity Monitor –  Ivar Nov 21 '12 at 23:50
    
I would suggest first to update to the latest Ubuntu kernel version. –  harrymc Nov 23 '12 at 7:03
    
I have upgraded the 12.04 distribution to the latest kernel as of Nov 26, 2012 (3.2.0-33-generic) and recompiled/reinstalled the vmware tools to no avail - the problem still exists. –  Ivar Nov 26 '12 at 17:35
    
Hi Darx! Please register your account here. For now I've merged the account you used for the question with the one from your answer now, but if you register here, you can always comment on your posts or edit your question to add more info. –  slhck Dec 11 '12 at 9:38
add comment

1 Answer

I would suggest first trying the mainline kernel rather than the Ubuntu one to see if the mainline still has this problem. The same problem used to happen in 10.04 under Xen with the default kernel.

If the mainline kernel doesn't fix the issue then try adding kernel parameter "acpi=off noapic" or disable irqbalance (worked for the same or similar issue; bug #1035855)

share|improve this answer
    
Thanks for the suggestion. Given that your suggestion strays from the chosen Ubuntu path (ie: not using the official distro kernel) I would say that at that point the problem either lies with VMWare (probably) or Ubuntu (much less likely). While I'd love a solution, going too far off the mainstream path into the weeds is too daunting to be practical. –  Ivar Nov 28 '12 at 17:33
    
You could still try those kernel options with the Ubuntu kernel to see if that helps. :) In the case where we ran into this with Xen it was actually definitely the Ubuntu kernel's fault and not an issue with the mainline. –  Nathan V Nov 29 '12 at 3:48
    
Not a specific answer, but you've provided the first major steps to debugging so I'll give you the bounty :) –  Ivar Nov 30 '12 at 0:17
    
Oh, cool. :) Have you had a chance to try the kernel option? –  Nathan V Nov 30 '12 at 3:30
    
I used "acpi=off noapic" but he problem still exists :/ i don't no what to do... :( –  Darx Dec 11 '12 at 8:26
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.