Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I trying to connect to my own computer over internet over port 3389, when i go to site yougetsignal can see that on my external ip port is open for sure. Also on firewall options Remote Assitance is allowed to connect on it from Public & Private network, and on properties is Allowed connection from internet. The router is set that port forward to my local ip. I can connect from local network to local ip address but when using external ip can not, why?

Can it be that router have some special security rules that restrict incoming connection, or something like that, cause I used too much time same method that work fine, but now don't.

Win 7

share|improve this question
    
What router are you using? –  leanne Nov 14 '12 at 20:14
    
the router is Enkom A1521-I –  tonni Nov 14 '12 at 20:24
    
Can you telnet to that 3389 port? If so, there could be some packet corruption. You may need to use protocol analysers to be sure. –  billc.cn Nov 14 '12 at 20:49
    
Do you have anything inbetween the router and your internet connection - a DSL or cable modem/router for example? If so, what model is it? –  leanne Nov 14 '12 at 20:53
    
@leanne between the Enkom router i have only cabel (computer is connected directly to router) –  tonni Nov 14 '12 at 20:55
show 10 more comments

2 Answers

up vote 1 down vote accepted

Can it be that router have some special security rules that restrict incoming connection, or something like that, cause I used too much time same method that work fine, but now don't.

Yes. I had the same issue with a new ARRIS router/cable modem combo from time warner. Using the same settings I have always used, the port forwarding 'worked' - but not if I tried to use the external address from an internal computer.

After much research, I traded it in for a slightly older Motorola surfboard, and it works as expected.

Two possible options if getting a new router isn't available - but these probably won't work well for multiple internal computers (especially if different ports get forwarded to different computers): on linux, use iptables to specify the specific usecase of that ip address as a local address. on windows, set up the computer to use a static ip the same as the external ip, as well as an internal ip.

share|improve this answer
    
thnx for effort with little later ... the problem was trivial i have to restart route five times to make them work correctly –  tonni Feb 19 '13 at 20:06
add comment

You likely need to enable port forwarding on your router. When you connect from the internet, you're connecting to your router, it doesn't know to forward traffic on port 3389 to your computer unless you tell it to.

For specifics on how do do this with your router, check this port forwarding guide, which has a large database of instructions for various routers. Generally you'll need to tell the router to forward port 3389 on the external IP to port 3389 at the IP of your computer (you'll probably want to set up a statically assigned IP for your computer as well).

share|improve this answer
    
thnx for answare but i did that and one thing that should be mentioned is that you have to tell port router where to forward port at internal ip cause you are connecting on external ip which than translate that port to your local ip address (your local computer) –  tonni Nov 14 '12 at 20:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.